Opened 9 years ago

Closed 8 years ago

#3714 closed enhancement (fixed)

Jukebox-26 design review

Reported by: garycmartin Owned by: humitos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Jukebox Version: Unspecified
Severity: Unspecified Keywords: design, patch, screenshot
Cc: manuq, garycmartin Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Jukebox-26 design review:

  • missing help hint for Add to playlist toolbar button
  • add to playlist and Remove from playlist should be a matching pair of icons -- proposal, use the (+) icon for Add to match the current (-) icon
  • place a separator after add/remove, before the Previous/Play/Next/Scrub slider to help separate the functionality and put more space between the destructive remove button and the rewind button
  • missing help hint for Play
  • "remove selected track from the playlist" not yet translated to Spanish & overly complex string -- propose using "Add track" & "Remove track" for the strings
  • slider next to the small volume toolbar icon is sub-optimal as the (otherwise unlabled) slider looks like it might control volume, where as the volume slider is actually hidden in a palette made by the small speaker icon (this is an old design flaw).
  • place track play head time text with the slider to make its function more obvious, something like M:SS -----o-----------------M:SS where the first M:SS is the current playhead position in minutes and seconds, and the last M:SS is the total track length
  • in the View secondary toolbar, swap the fullscreen and Show Playlist icons around to put the playlist icon nearer the real view
  • Use a standard Volume icon just after the View toolbar icon, place a volume slider in its secondary toolbar, include base and treble sliders if possible? Or if base/treble not something we can do, we should consider dropping the volume feature altogether, users can already control the volume with the keyboard and/or the Speaker device in the Frame, so control in Jukebox is only useful if it provides something more.

Attachments (12)

0001-Design-review-SL-3714.patch (3.7 KB) - added by humitos 9 years ago.
Patch with many of the points described on this ticket
46.png (26.0 KB) - added by humitos 9 years ago.
Screenshot of Jukebox with the patch applied
49.png (18.8 KB) - added by humitos 9 years ago.
With current and total times around the slider
0001-Current-and-total-time-SL-3714.patch (3.2 KB) - added by humitos 9 years ago.
19.png (26.1 KB) - added by humitos 9 years ago.
My interpretarion of the Gary's proposal on empty playlist
Jukebox_playlist_informational_only.png (16.7 KB) - added by garycmartin 9 years ago.
Jukebox_playlist_functional_and_informational.png (20.1 KB) - added by garycmartin 9 years ago.
0001-Modularization-of-classes.patch (91.2 KB) - added by humitos 8 years ago.
0002-Code-improved-for-better-performance-and-robustness.patch (49.6 KB) - added by humitos 8 years ago.
0003-Correct-playlist-width-at-start-up.patch (2.0 KB) - added by humitos 8 years ago.
0004-Show-No-media-message-when-Jukebox-starts-from-scrat.patch (9.8 KB) - added by humitos 8 years ago.
0005-Unfullscreen-when-no-more-streams.patch (1.7 KB) - added by humitos 8 years ago.

Download all attachments as: .zip

Change History (25)

comment:1 Changed 9 years ago by garycmartin

  • Cc manuq added
  • Owner changed from kushal to godiard
  • Status changed from new to assigned

I'll try to add some mockup proposals to help explain the text a little more later today.

comment:2 in reply to: ↑ description Changed 9 years ago by manuq

Replying to garycmartin:

Jukebox-26 design review:

  • missing help hint for Add to playlist toolbar button

Yes, needs tooltip.

self.open_button.set_tooltip(_('Add track'))
  • add to playlist and Remove from playlist should be a matching pair of icons -- proposal, use the (+) icon for Add to match the current (-) icon

Yes, it should be:

self.open_button = ToolButton('list-add')
  • place a separator after add/remove, before the Previous/Play/Next/Scrub slider to help separate the functionality and put more space between the destructive remove button and the rewind button

+1

  • missing help hint for Play

Yes, this icon changes graphic and behaviour, play - pause. Should the hint (tooltip) can be just "Play/Pause" all the time? Or change accordingly? there are methods set_button_play() and set_button_pause() that change the graphic, can change the tooltip too.

  • "remove selected track from the playlist" not yet translated to Spanish & overly complex string -- propose using "Add track" & "Remove track" for the strings

+1

  • slider next to the small volume toolbar icon is sub-optimal as the (otherwise unlabled) slider looks like it might control volume, where as the volume slider is actually hidden in a palette made by the small speaker icon (this is an old design flaw).

As Gonzalo said, maybe we can just remove the volume control, which is hidden as you said. It just changes the global sound anyway, that can be changed at the frame. And maybe we can display the time in numbers at the right of the slider.

  • place track play head time text with the slider to make its function more obvious, something like M:SS -----o-----------------M:SS where the first M:SS is the current playhead position in minutes and seconds, and the last M:SS is the total track length

Oh, that's what I was proposing above, great.

  • in the View secondary toolbar, swap the fullscreen and Show Playlist icons around to put the playlist icon nearer the real view

+1

  • Use a standard Volume icon just after the View toolbar icon, place a volume slider in its secondary toolbar, include base and treble sliders if possible? Or if base/treble not something we can do, we should consider dropping the volume feature altogether, users can already control the volume with the keyboard and/or the Speaker device in the Frame, so control in Jukebox is only useful if it provides something more.

I think we can just drop it.

comment:3 Changed 9 years ago by godiard

  • Owner changed from godiard to humitos

comment:4 Changed 9 years ago by humitos

I agree with all the points that you mentioned here.

I will take a look at this today and I will upload a screenshot.

Changed 9 years ago by humitos

Patch with many of the points described on this ticket

Changed 9 years ago by humitos

Screenshot of Jukebox with the patch applied

comment:5 in reply to: ↑ description Changed 9 years ago by humitos

  • Cc garycmartin added
  • Keywords patch screenshot added

These points are missing:

Replying to garycmartin:

  • missing help hint for Play

I didn't find the way to add tooltips to this button. It's not a common button, it's quite tuned.

  • place track play head time text with the slider to make its function more obvious, something like M:SS -----o-----------------M:SS where the first M:SS is the current playhead position in minutes and seconds, and the last M:SS is the total track length

I'm not sure how to do this and I don't have the image on my mind about how it should look as well. Can you draw something with the appearance that you have in your mind?

All of the other points mentioned here are in the patch that I've just attached

Changed 9 years ago by humitos

With current and total times around the slider

Changed 9 years ago by humitos

comment:6 follow-up: Changed 9 years ago by manuq

humitos, we should have a visible separator | instead of the empty space next to the +/- controls.

(sorry I didn't notice looking at your screen today)

comment:7 in reply to: ↑ 6 Changed 9 years ago by garycmartin

Replying to manuq:

humitos, we should have a visible separator | instead of the empty space next to the +/- controls.

(sorry I didn't notice looking at your screen today)

+1, the only invisible separator should be the expanding one before the Stop button to right align it.

comment:8 Changed 9 years ago by garycmartin

Hey, looking really good Humitos :)

I'll admit the one - so far unmentioned – item that has been slowly gnawing at me is the text title "No. Play List" for the play list section. My gut feeling is, the text title should be removed, and then a vertical & horizontal centred hint message, in grey, placed in that left playlist area. The message would be something like "Add a track" with the new (+) icon above it in the same grey as the text. See the Journal for a similar hint when the Journal is empty (or if a Journal search returns no entries). The message is only there if there are no tracks currently in the playlist (e.g. user selects nothing at start up, or later deletes the playlist empty), if the user has added tracks then that area is self evident already and doesn't need the text label.

Any opinion on this one?

Changed 9 years ago by humitos

My interpretarion of the Gary's proposal on empty playlist

comment:9 follow-up: Changed 9 years ago by humitos

Gary, I've just uploaded a screenshot that shows my interpretation about your proposal. What do you think?

Changed 9 years ago by garycmartin

Changed 9 years ago by garycmartin

comment:10 in reply to: ↑ 9 Changed 9 years ago by garycmartin

Replying to humitos:

Gary, I've just uploaded a screenshot that shows my interpretation about your proposal. What do you think?

Thanks, your mockup it goes a little further than I was proposing by adding functional button there as well (not a bad thing). I've attached a mockup of the simpler version, and your proposal for comparison. If it's not too much extra work, I prefer your proposal.

comment:11 follow-up: Changed 9 years ago by humitos

This screenshot is exactly what I tried to do: Jukebox_playlist_functional_and_informational.png

I prefer going on this way.

comment:12 in reply to: ↑ 11 Changed 9 years ago by manuq

Replying to humitos:

This screenshot is exactly what I tried to do: Jukebox_playlist_functional_and_informational.png

I prefer going on this way.

+1

Good stuff guys!

Changed 8 years ago by humitos

Changed 8 years ago by humitos

comment:13 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from assigned to closed

All these changes are already implemented

Note: See TracTickets for help on using tickets.