Opened 7 years ago

Closed 4 years ago

#3697 closed defect (fixed)

Speak adds ".." after each language choice

Reported by: greenfeld Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Speak Version: Unspecified
Severity: Unspecified Keywords: AU
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Speak-41 on OLPC 12.1.0 os13 & os14 adds ".." after each language choice in the drop-down selection dialog.

Speak-33 on OLPC 11.3.1 os885 does not do this.

Both XOs tested were running Sugar in Spanish.

Change History (8)

comment:1 Changed 7 years ago by cjl

It might have something to do with this line of code.

http://git.sugarlabs.org/speak/mainline/blobs/master/activity.py#line126

comment:2 Changed 7 years ago by cjl

123 self.voices = ComboBox()
124 for name in sorted(voice.allVoices().keys()):
125 vn = voice.allVoices()[name]
126 n = name [ : 26 ] + ".."
127 self.voices.append_item(vn, n)

comment:3 follow-up: Changed 6 years ago by RafaelOrtiz

I really like it with the '..' it gives the visual reference that there are more LANG in the combo.

comment:4 in reply to: ↑ 3 Changed 6 years ago by alsroot

Replying to RafaelOrtiz:

I really like it with the '..' it gives the visual reference that there are more LANG in the combo.

But it looks confusing, because eclipses in gtk says "there are more symbols, in the same string, to show", i.e., it is not a common practice that looks like a bug and better to avoid it.

comment:5 Changed 6 years ago by walter

Further, ellipsis is usually three "puntos" ... so it for some reason you decide to keep it, please add another dot.

comment:6 Changed 6 years ago by RafaelOrtiz

Ok seems better to avoid then. Following walter and aleksey's comments.

comment:7 Changed 4 years ago by paulcotton

  • Keywords AU added

comment:8 Changed 4 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

I fixed this in the up-coming release. I use ... when the language name is longer than 26 characters. Otherwise there is no ellipsis.

Note: See TracTickets for help on using tickets.