Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#3695 closed defect (fixed)

Write default font and font selection combo button do not match

Reported by: garycmartin Owned by: godiard
Priority: Unspecified by Maintainer Milestone:
Component: Write Version: Unspecified
Severity: Unspecified Keywords: olpc-test-passed
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Testing Write-79 on 12.1.0 build 13, XO-1.75

For a new activity instance, the font selection combo button defaults to "Sans", however the font used by default on the canvas is a serif font. Selecting some text and changing the combo from "Sans" to "Serif" (note the font change), and then back to "Sans" will show you a 3rd font, a real serif font this time, different from the one that is used by default on the canvas.

Change History (5)

comment:1 Changed 8 years ago by garycmartin

Also worth noting that the initial font used seems to be undefined as far as the combo button understands. Start a new document, type some text without changing the font, then change font and type again, then change the font and type again – so you have at least three texts in different fonts to experiment with. With the font combo button visible, move the insertion point cursor between the different text, the combo should update to match the font name... But with the first text in the default font, the combo does _not_ update, it does not know what combo item to display (it will just display whatever the last font name item was).

comment:2 Changed 7 years ago by godiard

  • Milestone changed from Unspecified by Release Team to 0.98

This is a regression.

comment:3 Changed 7 years ago by godiard

  • Keywords olpc-test-pending added
  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 7 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

Fixed in OLPC 13.1.0 os8.

comment:5 Changed 7 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.