Opened 8 years ago

Closed 7 years ago

#3678 closed defect (invalid)

Browse 129.1 crashes intermintently

Reported by: walter Owned by: erikos
Priority: Low Milestone: Unspecified
Component: Browse Version: 0.94.x
Severity: Unspecified Keywords:
Cc: humitos, walter Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

Context: Build 11.3.1 on an XO 1.5, Browse 129.1

After 10-12 sessions, Browse fails to launch and the laptop gets locked up (as if there were a OOM error.

I've attached both a log of the sugar shell and the browse session.

FWIW, there was only one other activity open at the time, Labyrinth.

Attachments (1)

org.laptop.WebActivity-12.log (938 bytes) - added by walter 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by walter

comment:1 Changed 8 years ago by walter

The shell.log is 20MB of dbus errors, too big to attach here. I cannot upload it to the wiki either... limited bandwidth where I am... the general thing is:

Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/jarabe/model/neighborhood.py", line 392, in active_activity_changed_cb

connection = self._connection[CONNECTION_INTERFACE_BUDDY_INFO]

TypeError: 'NoneType' object is not subscriptable
Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/jarabe/model/neighborhood.py", line 392, in active_activity_changed_cb

connection = self._connection[CONNECTION_INTERFACE_BUDDY_INFO]

TypeError: 'NoneType' object is not subscriptable
1339103597.855251 WARNING root: _Account.set_current_activity_cb
1339103597.856444 WARNING root: _Account.
set_current_activity_cb
(sugar-session:930): DEBUG: ice_io_error_handler (0x9752468)
(sugar-session:930): DEBUG: IceProcessMessagesIOError on '0x96354f0 [sugar-activity 1067e15490a70790fd133910354956939200000009300017]'
(sugar-session:930): DEBUG: xsmp_finalize (0x96354f0 [sugar-activity 1067e15490a70790fd133910354956939200000009300017])
1339103598.015077 ERROR root: set_active() failed: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
(sugar-session:930): DEBUG: xsmp_save_yourself ('0x8cc2c00 [sugar-activity 1067e15490a70790fd133908727739268700000009300001]', False)
Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/jarabe/model/neighborhood.py", line 392, in active_activity_changed_cb

connection = self._connection[CONNECTION_INTERFACE_BUDDY_INFO]

TypeError: 'NoneType' object is not subscriptable
Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/jarabe/model/neighborhood.py", line 392, in active_activity_changed_cb

connection = self._connection[CONNECTION_INTERFACE_BUDDY_INFO]

TypeError: 'NoneType' object is not subscriptable
1339103638.063396 WARNING root: _Account.set_current_activity_cb
1339103638.064629 WARNING root: _Account.
set_current_activity_cb
(sugar-session:930): DEBUG: accept_ice_connection()
(sugar-session:930): DEBUG: New client '0x9528830'
(sugar-session:930): DEBUG: Initializing client 0x9528830

then 20 MB of:

(sugar-session:930): DEBUG: Client '0x9528830' received RegisterClient(NULL)
(sugar-session:930): DEBUG: rejected: invalid previous_id

comment:2 Changed 7 years ago by humitos

  • Cc humitos walter added
  • Priority changed from Unspecified by Maintainer to Low

I couldn't reproduce it on 12.1.0 build 18- XO 1.5 and Browse 140

comment:3 Changed 7 years ago by humitos

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.