Opened 8 years ago

Closed 7 years ago

#3675 closed defect (obsolete)

TA stereo input channels swapped

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Each time you click on the stack, the L and R input channels are randomly swapped. Definitely seen on XO-1.75 by Tony and Guzman. Not sure about the 1.5.

I have vague recollections there is a buffer with alternating L and R values, if so it is possible its not getting cleared.

Guzman also says: "Solo funciona el canal derecho, pero con las labels "voltaje" y "resistencia", que corresponden al canal izquierdo!
Only the right channel works, but with the labels "voltage" and "Resistance", which correspond to the left channel!

I can read both channels OK

Change History (4)

comment:1 Changed 8 years ago by tonyforster

I have tried the XO-1.5 but I cant reproduce it on that model

comment:2 Changed 8 years ago by walter

Didn't have time to work on this before releasing v143 (which I needed this week in Peru). I have a few ideas where to look,

comment:3 Changed 8 years ago by walter

This is part of a more general issue with audio on the XO 1.75. Related to http://dev.laptop.org/ticket/11842

comment:4 Changed 7 years ago by walter

  • Resolution set to obsolete
  • Status changed from new to closed

1.75 no longer supports stereo capture.

Note: See TracTickets for help on using tickets.