Opened 8 years ago

Closed 8 years ago

#3674 closed defect (fixed)

Speak: Robot mode in spanish can't find the brain

Reported by: godiard Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Speak Version: Unspecified
Severity: Unspecified Keywords: 12.1.0
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Any question is replied "lo siento no puedo entender lo que estas preguntando" (sorry, i can't understand what you are asking)

In the log there are a error:

brain.py line 98, load_brain

brain = BOTS[voice.friendlyname]

KeyError: 'Espa\xc3\xb1ol'

Tested in version 41

Change History (3)

comment:1 Changed 8 years ago by alsroot

From IRC discussion. This particular fail occurs due to the fail with localizing Speak's gettext strings, i.e., "Spanish" is not translated as it should be.

comment:2 Changed 8 years ago by godiard

We need check if this is resolved in os13 with the changes in sugar code.

Anyway the code should be more robust if does not use translated keys.

comment:3 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Solved in os13. As expected related to sugar bug.

Note: See TracTickets for help on using tickets.