Opened 8 years ago

Closed 6 years ago

#3665 closed enhancement (fixed)

expose _is_fullscreen as a window property

Reported by: walter Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.96.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

There are times when an activity would like to know if it is in fullscreen mode. At present (0.96) this is stored in a private variable in window.py (self._is_fullscreen). Would it be OK to expose this as a property of the window?

IRC discussion

walterbender erikos: Is there any way to determine if an activity is in fullscreen mode other than looking at the private variable, _is_fullscreen ? Should that be exposed as a window property?
erikos walterbender: hey
erikos walterbender: let me take a quick look
erikos walterbender: hmm, I wonder if there are any downsides of exposing this
erikos walterbender: what do you want to do, to get a bit of background info
walterbender erikos: when I position the video in Turtle Art, its position is relative to the canvas, which moves when toolbars are expanded and or when in fullscreen mode
erikos walterbender: so this is about playback of a video, right?
walterbender erikos: yes
erikos walterbender: did you look what Records is doing?
walterbender erikos: will look.
erikos walterbender: is it a floating window? you can move around?
erikos s/window/widget
walterbender erikos: record seems to reimplement toggling in and out of fullscreen mode itself, disabling it in window.py
walterbender erikos: that is in part because record also uses the palette at the bottom of the screen.
walterbender erikos: I don't know how to play video except as a floating window
walterbender erikos: so the goal is to float it at the correct vertical offset, depending on the status of the toolbars
walterbender erikos: what do you think the downside of exposing _is_fullscreen as a property?
walterbender I could imagine other uses, such as an activity wanting to know if a toolbar was available.
erikos walterbender: yeah, at the moment I think there is no downside
erikos walterbender: what I am worried is that activities start to do crazy stuff when in fullscreen mode
walterbender erikos: crazy stuff???
walterbender erikos: I'll file a ticket as a task request for 0.98 and just reference the private variable in Turtle Art for the moment.
erikos walterbender: yes, sounds good
erikos walterbender: thanks

Change History (3)

comment:1 Changed 8 years ago by walter

  • Version changed from Unspecified to 0.96.x

comment:2 Changed 7 years ago by dnarvaez

  • Component changed from untriaged to sugar
  • Owner set to erikos

Temptatively assigning to sugar.

comment:3 Changed 6 years ago by Diego Naula

  • Resolution set to fixed
  • Status changed from new to closed

Fixes #3665: add is_fullscreen() method to Window class

Signed-off-by: Diego Naula <dnaula1997@…>

Changeset: ddd566c847ff2a78206ac10984291298e3344590

Note: See TracTickets for help on using tickets.