Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3661 closed defect (fixed)

Jukebox should always save a playlist with references to media

Reported by: manuq Owned by: manuq
Priority: Unspecified by Maintainer Milestone:
Component: Jukebox Version: Unspecified
Severity: Unspecified Keywords: 12.1.0
Cc: humitos, manuq, martin.langhoff Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by manuq)

Current playlist handling is a bit inconsistent, so the hopefully clear testcases below would help as specification. Journal current behaviour is to copy to the Journal a file that is stored in an external media, so Jukebox can't avoid that copy in today's Journal.

TestCases:

  • start Jukebox from scratch, close it
  • an empty playlist is stored, type: audio/x-mpegurl, size: empty, title: "Jukebox Activity"

Currently, the entry added to the journal is type: unknown.

  • start Jukebox from scratch, add one media, close
  • a playlist is stored, type: audio/x-mpegurl

Currently, the entry added to the journal is type: unknown, size: empty.

  • start Jukebox from scratch, add more than one media, close
  • a playlist is stored, type: audio/x-mpegurl

Currently, two entries are added to the journal. One is type:
audio/x-mpegurl, title: "Jukebox playlist". The other is type:
unknown, size: empty

  • start playlist (type: audio/x-mpegurl) with Jukebox, add one media, close
  • a playlist is stored, type: audio/x-mpegurl
  • start Jukebox from media inside journal, close
  • a playlist is stored, type: audio/x-mpegurl, title: "Jukebox playlist"
  • start Jukebox from media outside journal (ie Documents folder), close
  • the media is copied to the journal (as per Journal current behaviour [1])
  • also a playlist is stored, type: audio/x-mpegurl, title: "Jukebox playlist"

[1] sugar/src/jarabe/journal/misc.py resume() function

Attachments (1)

0001-Fix-playlist-behaviour-SL-3661.patch (5.0 KB) - added by manuq 8 years ago.
Proposed fix.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by humitos

  • Cc humitos added

comment:2 Changed 8 years ago by humitos

  • Cc manuq added

Can you explain here a bit more this issue?

I think that the first time that we add a song in the Playlist the song (.ogg) is copied to the XO (on the Journal) and the second time the Playlist (.m3u) is copied to the XO with the references to the song files (no .ogg is copied on the XO).

So, Jukebox should work everytime as the second time that I described above, am I right?

Thanks,

comment:3 Changed 8 years ago by manuq

  • Description modified (diff)

Changed 8 years ago by manuq

Proposed fix.

comment:4 Changed 8 years ago by manuq

  • Description modified (diff)

comment:5 Changed 8 years ago by godiard

  • Cc martin.langhoff added

The behavior is consistent:

  • If the user open Jukebox and select media with the ObjectChooser, the media file is not copied to the Journal and a play list is created.
  • If the media is already in the Journal, a play list is created.
  • If the user go to the Journal, select a external device or Documents directory and click over a media file, the file is copied to the Journal and Jukebox starts, but this is a Journal behavior, we can't do anything in the activity. I think it's ok, because is consistent with other activities (Read do the same), and if the user know to open media without copying need open Jukebox activity first.

+1 from my part to this patch.

comment:6 Changed 8 years ago by humitos

I think there is a big difference between Jukebox and all the rest of the activities as you mention (Read, for example). Jukebox deals with .mp3 file (usually ~3Mb file size), so I think that we shouldn't copy them to the Journal (XO "hard disc") without the explicit consent of the user.

Imagine what would happen if the .mp3 is a complete concert of something, it will be bigger than 3Mb, maybe 60Mb. I wouldn't to copy that to my XO.

comment:7 Changed 8 years ago by manuq

  • Resolution set to fixed
  • Status changed from new to closed

This was applied, thanks for the testing. A new bug found deserves attention: #3709 . I will close this one.

comment:8 Changed 7 years ago by dnarvaez

  • Milestone 0.96 deleted

Milestone 0.96 deleted

Note: See TracTickets for help on using tickets.