Opened 8 years ago

Closed 8 years ago

#3657 closed enhancement (fixed)

Marks for tune an instrument

Reported by: humitos Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Measure Version: Unspecified
Severity: Unspecified Keywords:
Cc: humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

After seeing this video I thought that it could be good to add a Guitar icon that adds some vertical bars to the background with the correct position for each chord.

We can expand this idea to more instruments. I'm opening this ticket to discuss a bit more about this.

Change History (10)

comment:1 Changed 8 years ago by walter

  • Status changed from new to accepted

Nice idea.

comment:2 Changed 8 years ago by AlanJAS

Good! But the Measure activity have a lot of options; maybe add more, it's confused?
If we make another activity (called Tune, for example) more simple that only serve to tune an instrument. We can add instruments: guitar, violin, etc..

comment:3 Changed 8 years ago by humitos

I agree with you about that there are too many buttons, but creating a new activity will break the relationship between "measure sound" and "tune an instrument". I mean, "tune a guitar" will be the answer for: "What the hell I can do with this activity?", "OK, It's for measure waves. I can speak and it will show me the wave of my voice", "Wow!, I can tune an instrument", "How does it work?"

In my personal experience, I know some guitarist that have no idea about that relationship: measure the sound and look for the correct wave.

It would be good if we think in a GUI that solves this confusing problem with all the buttons.

comment:4 Changed 8 years ago by humitos

comment:5 Changed 8 years ago by AlanJAS

Well, who makes this improvment?

comment:6 Changed 8 years ago by walter

I've begun this work. Hope to land it soon.

-walter

comment:8 in reply to: ↑ 7 Changed 8 years ago by humitos

Replying to walter:

Please test [1].

Cool! It works for me. Just a comment: I'd use capital letters for the names of the instruments in the ComboBox

Another comment, I tested it with my electric guitar, so I just tested "guitar". I tried the other instruments and the lines are drawn but I don't know if they are OK. I trust on you :)

comment:9 Changed 8 years ago by walter

Thanks for testing. The other instruments are pretty standard ones. See [1]. Be interesting to add some non-Western instruments as well.

[1] http://en.wikipedia.org/wiki/Piano_key_frequencies

comment:10 Changed 8 years ago by walter

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.