Opened 8 years ago

Last modified 8 years ago

#3640 new defect

If jabber.sugarlabs.org is connected via a wireless AP, or wired network, e-toys will not start:

Reported by: satellit Owned by: bert
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Etoys Version: 0.96.x
Severity: Unspecified Keywords: etoys, jabber, presence-service
Cc: pbrobinson, tomeu, erikos, humitos Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

I have been testing the RC4 f17 release of SoaS [1] and I see a problem with e-toys:
If jabber.sugarlabs.org is connected via a wireless AP, or wired network, e-toys will not start:

DBusError: Process /usr/bin/sugar-presence-service exited with status 1

Etoys runs fine if wireless is not logged in and/or wired network is not connected. (no jabber connected)

As Etoys is a favorite on the f3 ring and f17 release is imminent, I feel that this is an important bug to look at.

Sugar on a Stick 7 (Quandong)
Fedora release 17 (beefy Miracle)
0.96.1

Tom Gilliard
satellit_

tested with dd usb and liveinst HD install

[1] http://dl.fedoraproject.org/pub/alt/stage/17.RC4/Spins/x86_64/Fedora-17-x86_64-Live-SoaS.iso

Change History (5)

comment:1 Changed 8 years ago by satellit

  • Cc pbrobinson added

Also confirmed in VirtualBox install of Fedora-17-i686-Live-SoaS.iso

If after HD install to Virtualbox; network is turned off E-toys starts example as expected.

when started with network connection on; DBusError message returns.

Note that if (X) on top left corner of error message is clicked you can draw and save files locally with E-toys.
It may be the DbusError shown is only due to the starting example, which requires /usr/bin/sugar-presence-service to be present.

comment:2 Changed 8 years ago by bert

  • Cc tomeu erikos added

This is because the presence service crashes:

Traceback (most recent call last):
  File "/usr/bin/sugar-presence-service", line 24, in <module>
    main.main()
  File "/usr/share/sugar-presence-service/main.py", line 64, in main
    presenceservice.main(test_num, randomize)
  File "/usr/share/sugar-presence-service/presenceservice.py", line 894, in main
    ps = PresenceService()
  File "/usr/share/sugar-presence-service/presenceservice.py", line 106, in __init__
    self._server_plugin = ServerPlugin(self._registry, self._owner)
  File "/usr/share/sugar-presence-service/server_plugin.py", line 59, in __init__
    TelepathyPlugin.__init__(self, registry, owner)
  File "/usr/share/sugar-presence-service/telepathy_plugin.py", line 147, in __init__
    self._init_connection()
  File "/usr/share/sugar-presence-service/telepathy_plugin.py", line 195, in _init_connection
    self._handle_connection_status_change(status, CONNECTION_STATUS_REASON_NONE_SPECIFIED)
  File "/usr/share/sugar-presence-service/telepathy_plugin.py", line 223, in _handle_connection_status_change
    self._connected_cb()
  File "/usr/share/sugar-presence-service/server_plugin.py", line 193, in _connected_cb
    TelepathyPlugin._connected_cb(self)
  File "/usr/share/sugar-presence-service/telepathy_plugin.py", line 469, in _connected_cb
    self._subscribe_channel_cb(channel)
  File "/usr/share/sugar-presence-service/server_plugin.py", line 274, in _subscribe_channel_cb
    TelepathyPlugin._subscribe_channel_cb(self, channel)
  File "/usr/share/sugar-presence-service/telepathy_plugin.py", line 428, in _subscribe_channel_cb
    subscribe_handles)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "RequestPresence" with signature "au" on interface "org.freedesktop.Telepathy.Connection.Interface.Presence" doesn't exist

comment:3 Changed 8 years ago by bert

Sugar 0.96 actually requires Etoys 5, which is more robust wrt presence service failures. I just tried in Fedora-17-i686-Live-SoaS, Etoys 5 does not produce an error like Etoys 4.1, but starts up just fine.

comment:5 Changed 8 years ago by bert

This can be solved in two ways: Re-implement the presence service in Etoys (which I'm working on, but will take time) or fix /usr/bin/sugar-presence-service (which worked still fine in Sugar 0.94).

Note: See TracTickets for help on using tickets.