Opened 7 years ago

Closed 5 years ago

#3635 closed defect (obsolete)

Activity icon in menu bar may jump in position when exiting activity

Reported by: greenfeld Owned by: erikos
Priority: Low Milestone: Unspecified
Component: Sugar Version: 0.96.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

This can be hard to see, and I'm not certain what causes it, but:

  1. Start the Chat or Distance activities.
  2. Share the activity on an XO.
  3. Have another XO join the activity.
  4. On the first XO quit out of the activity using Ctrl-Q or the Stop button.

The activity's icon in Sugar menu bar shown in the user's colors will jump diagonally to up and to the left just prior to the activity quitting. Sometimes this jump is seen at step #2 as well without leaving the activity.

I am not certain if collaboration is required to see this but it seems to help. When I see this I can repeat it over and over again. When it doesn't show it is hard to provoke.

Seen in OLPC 12.1.0 os11 on more than one XO version.

Change History (4)

comment:1 Changed 7 years ago by greenfeld

Still seen in OLPC 13.1.0 os1/Sugar 0.97.1.

comment:2 Changed 6 years ago by erikos

comment:3 Changed 5 years ago by walter

  • Priority changed from Unspecified by Maintainer to Low

comment:4 Changed 5 years ago by godiard

  • Resolution set to obsolete
  • Status changed from new to closed

I can't reproduce the issue, and didn't see it for a long time. in the meantime Chat was ported to Gtk3, not sure if was related to gtk2.

Closing now, if is found again can be reopened.

Note: See TracTickets for help on using tickets.