Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#3631 closed defect (fixed)

UserAgent of Browse contains "Sugar Labs/0.96"

Reported by: bernie Owned by: manuq
Priority: Low Milestone:
Component: Browse Version: 0.96.x
Severity: Unspecified Keywords:
Cc: erikos, bert, humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

There's no clear standard for UserAgent strings, but embedding a space within one of its parts seems dangerous, because space is also used to separate such parts from one another.

I propose changing it to "Sugar/0.96", but "SugarLabs/0.96" would also do.

Change History (12)

comment:1 Changed 8 years ago by bernie

  • Cc erikos added
  • Owner changed from erikos to manuq
  • Status changed from new to assigned

Reassigning to manuq as I was told that he takes care of Browse nowadays.
Erikos, should we change the module owner in Trac to reflect this?

comment:2 follow-up: Changed 8 years ago by manuq

  • Cc bert added

I don't have objections Bernie. We should change both, ASLO and Browse. Also, wasn't squeakland.org reading the User-Agent for Etoys projects too? Adding bert in the CC.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 8 years ago by bernie

Replying to manuq:

I don't have objections Bernie. We should change both, ASLO and Browse. Also, wasn't squeakland.org reading the User-Agent for Etoys projects too? Adding bert in the CC.

I don't see anything equivalent to "Sugar Labs/0.96" in the UserAgent string of the versions of Browse based on xulrunner.

Now I'd be curious to know how ASLO detects the version of Sugar of the client.

comment:4 Changed 8 years ago by bert

Yes, Squeakland looks at the user agent - right now only for the substring "olpc" because newer Browse versions did not have any equivalent.

comment:5 in reply to: ↑ 3 Changed 8 years ago by sascha_silbe

Replying to bernie:

I don't see anything equivalent to "Sugar Labs/0.96" in the UserAgent string of the versions of Browse based on xulrunner.

Yes, it broke some time ago, see SL#2834.

Now I'd be curious to know how ASLO detects the version of Sugar of the client.

See SL#1066 for the original patch for xulrunner based Browse.

As explained on sugar-devel, we should use the Sugar Platform version for the User-Agent header (i.e. SugarPlatform/0.96 rather than Sugar/0.96). Unfortunately, there's currently no good way to detect it.

comment:6 Changed 7 years ago by humitos

  • Priority changed from Unspecified by Maintainer to Low

comment:7 Changed 7 years ago by humitos

  • Cc humitos added

comment:8 Changed 7 years ago by manuq

  • Milestone changed from Unspecified by Release Team to 1.0

comment:11 Changed 7 years ago by manuq

  • Resolution set to fixed
  • Status changed from assigned to closed

Pushed Browse part as 6901af4e .

comment:12 Changed 7 years ago by dnarvaez

  • Milestone 1.0 deleted

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.