Opened 8 years ago

Closed 6 years ago

#3612 closed defect (obsolete)

"My settings" pop-up deny the ability to reach the frame at corners

Reported by: humitos Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: humitos, manuq Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Steps to reproduce it:

  1. Open TurtleArt (or some activity that spend some seconds to start)
  2. Go to the Home View by pressing F3
  3. Right-Click on the Child at the center of the screen
  4. Click on "My settings"
  5. A pop-up is opened to change your settings
  6. Wait there
  7. TurtleArt is opened

Issue:

  • Try to reach the frame at corners
  • Go Home and try to open another activity

"My settings" pop-up blocks Sugar. The only way to close this pop-up is by pressing Alt+Tab some times to reach the pop-up and close it.

Expected behavior:

Don't block Sugar at all. How? I don't know :)

Environment:

XO 1.5 - os10

Change History (4)

comment:1 Changed 8 years ago by godiard

I could reproduce it here. This bug remember me when we needed set the parent.xid in the ObjectChooser...

comment:2 follow-up: Changed 7 years ago by humitos

Another way to reproduce this error:

  1. Go to one corner with the mouse
  2. Click on the XO guy and then on "My settings" (the frame is still there)
  3. Go to one corner again trying to hide the frame

It's not possible to hide the frame with the mouse but if I do the gesture with my finger I can hide/show it.

I tested this in XO-4 os7

comment:3 in reply to: ↑ 2 Changed 7 years ago by manuq

Replying to humitos:

Another way to reproduce this error:

  1. Go to one corner with the mouse
  2. Click on the XO guy and then on "My settings" (the frame is still there)
  3. Go to one corner again trying to hide the frame

It's not possible to hide the frame with the mouse but if I do the gesture with my finger I can hide/show it.

This is a different issue #4071

comment:4 Changed 6 years ago by manuq

  • Resolution set to obsolete
  • Status changed from new to closed

The behavior was changed and activities do not open on top of My Settings dialog now. And by design the dialog is modal, and the frame can't be reached when the dialog is open.

Note: See TracTickets for help on using tickets.