Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#3610 closed defect (fixed)

Pop-up window is opened when export to HTML

Reported by: humitos Owned by: humitos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Write Version: Unspecified
Severity: Unspecified Keywords:
Cc: godiard Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Steps to reproduce it:

  1. Open Write
  2. Type something
  3. Export the document as HTML

Issue:

A pop-up window is opened to select some export settings.

Expected behavior:

Don't open a pop-up window. Those export settings should be set by default.

Attachments (2)

write-html-export-pop-up.png (68.8 KB) - added by humitos 8 years ago.
test_abiword.py (696 bytes) - added by humitos 8 years ago.

Download all attachments as: .zip

Change History (13)

Changed 8 years ago by humitos

comment:1 Changed 8 years ago by humitos

I tried to find the pyabiword documentation and I just found this link:

Where is documented the abiword.save method called when you press the export to HTML button but it doesn't say too much:

gboolean save(const gchar* fname, constgchar* extention_or_mimetype, const gchar* exp_props)

I think we should look at the C source code to know how it works. This link could be useful:

comment:2 Changed 8 years ago by humitos

I tried to modify this Python example[1] using the .save method and avoiding the dialog but I couldn't (attached my script)

[1] http://www.abisource.com/wiki/PyAbiWord

Changed 8 years ago by humitos

comment:3 Changed 8 years ago by humitos

I sent an email to the abiword mailing list. The link will appear here in a couple of hours:

comment:5 Changed 8 years ago by humitos

J.M. Maurer <uwog@…> told me that the only way to do this is patching the C++ source code to avoid calling the Dialog.

I think that we should modify this file:

comment:7 Changed 8 years ago by erikos

Reading Mark's reply he said that there was a patch to disable the HTML exporter dialog, and that this was part of the rpm. Peter removed that at one point:

commit d197fb223accd5785d90373413589ad6cdb180be
Author: Peter Robinson <pbrobinson@gmail.com>
Date:   Thu Aug 4 00:32:18 2011 +0100

    rebuild for new asio, drop obsolete OLPC and ARM includes

diff --git a/abiword.spec b/abiword.spec
index e983cb9..d9491fa 100644
--- a/abiword.spec
+++ b/abiword.spec
@@ -2,12 +2,10 @@
 %define minorversion 8
 %define microversion 6
 
-%define olpc_build 0
-
 Summary: The AbiWord word processor
 Name: abiword
 Version: %{majorversion}.%{minorversion}.%{microversion}
-Release: 12%{?dist}
+Release: 13%{?dist}
 Epoch: 1
 Group: Applications/Editors
 License: GPLv2+
@@ -30,11 +28,6 @@ Patch0: abiword-2.6.0-windowshelppaths.patch
 Patch1: abiword-2.8.3-desktop.patch
 Patch2: abiword-2.6.0-boolean.patch
 Patch3: abiword-plugins-2.6.0-boolean.patch
-%if %{olpc_build}
-Patch100: abiword-2.6.4-defaultfont.patch
-Patch101: abiword-2.6.4-draghandles.patch
-Patch102: abiword-2.6.4-nohtmloptions.patch
-%endif
 Patch103: abiword-2.8.6-libwpd.patch
 Patch104: abiword-2.8.6-no-undefined.patch
 

comment:8 Changed 8 years ago by humitos

  • Owner changed from godiard to humitos
  • Status changed from new to accepted

comment:9 Changed 8 years ago by manuq

This was in 11.3 too.

comment:10 Changed 7 years ago by godiard

  • Resolution set to fixed
  • Status changed from accepted to closed

Is not happening with our abiword 2.9.3 rpm, and the patch is not included.

Close this ticket, can be openened if happen again, but looks like was solved in abiword.

comment:11 Changed 7 years ago by humitos

  • Cc godiard added

I've just tested this on XO-4 13.1.0 os8 Write v82 and I'm having this issue.

I have installed abiword.arm7hl 1:2.9.3-1.git20121011.fc18.olpc3.

Is that the correct package to test this?

Note: See TracTickets for help on using tickets.