Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3608 closed defect (fixed)

dita/ditamap exported file type is not supported by Browse

Reported by: humitos Owned by: humitos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: InfoSlicer Version: Unspecified
Severity: Unspecified Keywords: patch
Cc: humitos, manuq, godiard Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Steps to reproduce it:

  1. Open InfoSlicer
  2. Create an article
  3. Export your work
  4. Go to the Journal
  5. Open your exported work

Issue:

Sugar will try to open this type of file with Browse by default, but Browse doesn't know how to handle this kind of file.

Expected behavior:

I'm not sure. I think this is not a Browse problem, I think we should avoid using dita/ditamap format to export InfoSlicer contents and use simple HTML instead.

The discussion is open here.

Attachments (2)

test.xol (19.9 KB) - added by walter 8 years ago.
.dita --> .xnl
0001-Export-content-as-HTML.patch (4.7 KB) - added by humitos 8 years ago.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by walter

.dita --> .xnl

comment:1 Changed 8 years ago by walter

The attached bundle opens with firefox but not Browse...

comment:2 Changed 8 years ago by godiard

Firefox can open a xml file with a xsl stylesheet. Looks like webkit can't do it.

I think the best option is generate html files.

comment:3 Changed 8 years ago by humitos

  • Owner changed from walter to humitos
  • Status changed from new to accepted

Changed 8 years ago by humitos

comment:4 Changed 8 years ago by humitos

  • Keywords patch added

comment:5 Changed 8 years ago by humitos

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:6 Changed 8 years ago by humitos

This will be available on v15

Note: See TracTickets for help on using tickets.