Opened 8 years ago

Closed 8 years ago

#3599 closed defect (fixed)

TA139 rabbit mode coordinate display

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Rabbit mode does not update the coordinate display, which is probably a good thing. Coordinates should be blanked in the view toolbar in rabbit mode.

Change History (10)

comment:1 Changed 8 years ago by walter

I experimented with updating during program execution, and, as you predict, it was very slow. However, I think it should update once the program has run to completion or is stopped by the user or an error. I thought that is how I had it currently set up. Is is not working?

comment:2 Changed 8 years ago by tonyforster

Yes, I expect that is what is happening, but during execution the displayed values are wrong.

comment:3 follow-up: Changed 8 years ago by walter

So your proposal would be to blank out the display until there are valid numbers to display. Makes sense to me.

comment:4 in reply to: ↑ 3 Changed 8 years ago by tonyforster

Replying to walter:

So your proposal would be to blank out the display until there are valid numbers to display. Makes sense to me.

yes

comment:5 Changed 8 years ago by tonyforster

"I think it should update once the program has run to completion or is stopped by the user"

I checked, it doesn't update on completion or stop.

comment:6 Changed 8 years ago by walter

Please try [1] to see if it results in the desired behavior.

[1] http://git.sugarlabs.org/turtleart/mainline/commit/a01b019f06771ba88db68d01fab32774049603ed

comment:7 Changed 8 years ago by tonyforster

No, at end of the stack, the blocks are not unhidden nor coordinates displayed
for stop or error blocks are unhidden and coordinates displayed

comment:8 Changed 8 years ago by walter

end of stack does not unhide blocks or display coordinates

That is by design, because you may want to look at the results without
the blocks in the way. There is a Show Blocks icon that replaces the
Stop button that should make the blocks reappear. (Will have to check
to make sure it also updates the coordinate display.)

error or stop does unhide blocks and display coordinate

Really? That is a bug. Will investigate further.

comment:9 Changed 8 years ago by tonyforster

all fixed, working as designed, just misunderstood communications
end of stack, blocks are hidden
manual stop or error, blocks are displayed

comment:10 Changed 8 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.