Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3597 closed defect (fixed)

Browse: title in tab not correct with pdf

Reported by: erikos Owned by: humitos
Priority: Unspecified by Maintainer Milestone:
Component: Browse Version: 0.96.x
Severity: Major Keywords: 12.1.0 olpc-test-passed
Cc: humitos Distribution/OS: Unspecified
Bug Status: New

Description

The title is still 'Loading...' in the url entry, in the tab title of the pdf and in the one of the tab i opened it from. (I did open by typing in the url directly, clicking case not tested)

Attachments (3)

loading_issue.png (309.8 KB) - added by erikos 8 years ago.
Screenshot of _solar_system.pdf_.png (659.2 KB) - added by humitos 8 years ago.
0001-Fix-for-displaying-filename-in-untitled-PDFs-SL-3597.patch (1.6 KB) - added by manuq 8 years ago.
Fix for PDF files without title

Download all attachments as: .zip

Change History (14)

Changed 8 years ago by erikos

comment:1 Changed 8 years ago by humitos

What Browse should show there? The name of the pdf file?

comment:2 Changed 8 years ago by garycmartin

If you can access the title of the pdf document that would be great (title is part of the PDF metadata so might be tough to get at). I had a quick look at Safari and Chromes behaviour, they both only show the full URL as the tab name, not verry helpful as the name is often longer than the space in a tab so you might not see anything unique in the name when viewing pages from the same site.

comment:3 Changed 8 years ago by humitos

  • Owner changed from manuq to humitos
  • Status changed from new to accepted

comment:4 Changed 8 years ago by humitos

I don't have the behavior that you described here.

I'm testing this on XO 1.5 os9 Browse 137.

If I type the URL of the pdf file (http://samplepdf.com/sample.pdf) a new tab is opened with the correct title of the pdf file (Microsoft Word - sample.pdf.docx) but the original tab stills saying "Loading..." and "Untitled".

If I search on Google "sample pdf" and click on that link a new tab is opened with the correct pdf title and the google tab stills opened saying "Loading..." but it is doing nothing (I still seeing the google search on this tab)

Where did you find this issue?

comment:5 Changed 8 years ago by manuq

TestCase:

  • in the olpc start page, go to Books > Books and texts
  • hit Solar System
  • a new tab is opened with the PDF, and both tab labels say "Loading..." instead of the title

comment:6 Changed 8 years ago by humitos

manuq, where did you test this?

I followed the steps that you mentioned and I couldn't reproduce it on XO 1.5 os9. Browse 136.

Changed 8 years ago by humitos

Changed 8 years ago by manuq

Fix for PDF files without title

comment:7 Changed 8 years ago by manuq

The attached patch fixes the case for untitled PDF displaying "Loading..." after the load is done.

The case of the previous tab displaying "Loading..." is being tracked in #3620 .

comment:8 Changed 8 years ago by humitos

Tested and it worked. Please, push this patch.

comment:9 Changed 8 years ago by manuq

  • Keywords 12.1.0 olpc-test-pending added
  • Resolution set to fixed
  • Status changed from accepted to closed

comment:10 Changed 8 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

The PDF title is provided if in the PDF; otherwise we see the filename in 12.1.0 os16/Browse-140.

comment:11 Changed 7 years ago by dnarvaez

  • Milestone 0.96 deleted

Milestone 0.96 deleted

Note: See TracTickets for help on using tickets.