Opened 9 years ago

Closed 7 years ago

#3584 closed enhancement (fixed)

Remove sleeping face in Maze

Reported by: manuq Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Maze Version: Unspecified
Severity: Unspecified Keywords:
Cc: humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Any reason to have the sleeping face? Also, is out of style.

Change History (8)

comment:1 follow-up: Changed 9 years ago by humitos

  • Cc humitos added

What is the sleeping face? Is the face that is shown when you leave the computer for a while?

comment:2 Changed 9 years ago by garycmartin

It was a pygame power saving feature when the game is left idle for a short while, not sure if it is still a valid case. Certainly the design is out of style with Sugar. Ideally Maze would pause it's pygame run loop invisibly when not needed, no user feedback necessary (need to test pause behaviour during a shared game).

comment:3 in reply to: ↑ 1 Changed 9 years ago by manuq

Replying to humitos:

What is the sleeping face? Is the face that is shown when you leave the computer for a while?

Yes. No other activity has an idle indicator.

comment:4 Changed 9 years ago by humitos

Yes. It's a power saving feature but I'm not sure if on the XO is necessary, because the XO has its own power saving feature.

comment:5 Changed 9 years ago by RafaelOrtiz

i like the cute addition of having an idle indication, though I don't know if its practical, I don't see a real issue in having it, at least it has conflicts with XO's power management.

comment:6 Changed 9 years ago by humitos

If it has something to do with the power saving system (I mean, it do work), maybe we should change the image (because it's out of style and has nothing to do with the rest) instead of removing it.

comment:7 Changed 9 years ago by RafaelOrtiz

+1 to changing the image. if someone has a sketch or suggestion is welcomed.

comment:8 Changed 7 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Removed on version 25.

If we want implement something like this, should be done on sugar-toolkit-gtk3, to be available to all the activities in a consistent way.

Note: See TracTickets for help on using tickets.