Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#3561 closed defect (fixed)

Read bookmark entry/edit Details area lacks border around text entry area

Reported by: greenfeld Owned by: manuq
Priority: Unspecified by Maintainer Milestone:
Component: Read Version: Unspecified
Severity: Unspecified Keywords: 12.1.0, patch, olpc-test-passed
Cc: humitos Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

The Read activity's bookmark entry/edit Details area lacks a visible border around its text entry area.

The single-line bookmark title entry area does have a visible border.

Seen with a PDF file in OLPC 12.1.0 os8/Read-99.

Attachments (8)

Screenshot of _The Call of the Wild, by Jack London__2.png (39.4 KB) - added by humitos 9 years ago.
Captura pantalla de _sampletext.dvi_.png (68.8 KB) - added by humitos 9 years ago.
TextView with borders
bookmark-textview-with-borders.diff (607 bytes) - added by humitos 9 years ago.
Not final patch, just an example
0001-Borders-in-the-Bookmark-Description-entry-SL-3561.patch (1.2 KB) - added by humitos 9 years ago.
This is the correct patch - using the enumerates provided by Gtk (thanks manuq)
0001-Borders-in-the-Bookmark-Description-entry-SL-3561.2.patch (1.2 KB) - added by humitos 9 years ago.
This is the correct patch - using the enumerates provided by Gtk (thanks manuq)
0001-Make-toolbars-black-background-SL-3403.patch (993 bytes) - added by manuq 9 years ago.
0002-Theme-ScrolledWindow-frame-SL-3561.patch (1.2 KB) - added by manuq 9 years ago.
0002-Theme-ScrolledWindow-frame-SL-3561.patch-2 (1.2 KB) - added by manuq 9 years ago.
Second version of the ScrolledWindow frame styled.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 9 years ago by godiard

  • Keywords 12.1.0 added

comment:2 Changed 9 years ago by humitos

  • Cc humitos added

I could reproduce this issue in XO 1.75 os12

comment:3 Changed 9 years ago by humitos

  • Owner changed from godiard to humitos
  • Status changed from new to accepted

Changed 9 years ago by humitos

TextView with borders

Changed 9 years ago by humitos

Not final patch, just an example

comment:4 Changed 9 years ago by humitos

I don't know how to import this constant from Python (that is why I used just numbers):

and I don't know how to make the corners rounded. Maybe this is a theme issue. I'm not sure.

Changed 9 years ago by humitos

This is the correct patch - using the enumerates provided by Gtk (thanks manuq)

Changed 9 years ago by humitos

This is the correct patch - using the enumerates provided by Gtk (thanks manuq)

comment:5 Changed 9 years ago by erikos

  • Milestone changed from Unspecified by Release Team to 0.96

comment:6 Changed 9 years ago by erikos

Ok, so we should probably do all of the theming of the dialog in sugar-artwork and revert the work around Gonzalo did inside Read in 0c4072cd9667222df883684ae26364c973c90773.

comment:7 Changed 9 years ago by humitos

  • Owner changed from humitos to manuq
  • Status changed from accepted to assigned

OK. I'm re-assigning this ticket to manuq, because he is on the theme.

comment:8 Changed 9 years ago by humitos

  • Keywords patch added

comment:9 Changed 9 years ago by manuq

What is not working is the set of the shadow type in a Gtk.ScrolledWindow, in Read readdialog.py is set as:

sw = Gtk.ScrolledWindow()
...
sw.set_shadow_type(Gtk.ShadowType.ETCHED_IN)

comment:10 Changed 9 years ago by manuq

Found how to style the ScrolledWindow shadow, is in the second patch.

The first one fixes the theme so Read workaround in commit 0c4072cd9667222df883684ae26364c973c90773 can be removed.

comment:11 Changed 9 years ago by erikos

Should we do a:

padding: $(default_padding)px;

to breath a bit more when taking bookmark notes :)

And yes, the Read patch can be removed with this fix.

comment:12 Changed 9 years ago by manuq

Thanks for reviewing Simon, you are right about the padding. I attach a second version.

Changed 9 years ago by manuq

Second version of the ScrolledWindow frame styled.

comment:13 Changed 9 years ago by manuq

  • Keywords olpc-test-pending added
  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks, pushed.

comment:14 Changed 9 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

The border is present in Read-99/OLPC 12.1.0 os16. Tested on XO-1 and XO-1.75.

comment:15 Changed 8 years ago by dnarvaez

  • Milestone 0.96 deleted

Milestone 0.96 deleted

Note: See TracTickets for help on using tickets.