Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#3553 closed enhancement (fixed)

Display only the url in the url entry

Reported by: erikos Owned by: humitos
Priority: Normal Milestone:
Component: Browse Version: Git as of bugdate
Severity: Unspecified Keywords: 12.2.0, design, patch
Cc: manuq, garycmartin, humitos Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

The first versions of the Browse activity had no tabs. We needed a way to display the url and the title in the UI. We did a trick and used the hovering over the entry to switch between displaying the title or the url. This worked, but was subuptinmal and leaded to a few confusions.

The good news is, that now with tabs we have one more area where we can display such information, the tab. So like in Safari on the iPad we could reserve the url entry for the url and put the title in the tab.

Attachments (1)

0001-Display-only-the-URL-in-the-URL-entry-SL-3553.patch (7.6 KB) - added by humitos 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by humitos

  • Cc humitos added
  • Keywords design added
  • Priority changed from Unspecified by Maintainer to Normal

The width of the tab is not enough (mostly) to keep the complete title of the URL, so I think we should add a hover on it to display a palette with the complete title as well.

comment:2 Changed 9 years ago by humitos

  • Owner changed from erikos to humitos
  • Status changed from new to accepted

comment:3 follow-up: Changed 9 years ago by humitos

I had to add a new property in Browse class to save the url entered by the user. This is because if we switch over the tabs we will get a None uri if the page can not be loaded yet.

So, I'm saving the effective_url in this property (loading_url) and I'm showing it if browser.pops.uri is None.

comment:4 Changed 9 years ago by humitos

  • Keywords patch added

comment:5 in reply to: ↑ 3 Changed 9 years ago by manuq

  • Resolution set to fixed
  • Status changed from accepted to closed

Replying to humitos:

I had to add a new property in Browse class to save the url entered by the user. This is because if we switch over the tabs we will get a None uri if the page can not be loaded yet.

So, I'm saving the effective_url in this property (loading_url) and I'm showing it if browser.pops.uri is None.

Good, but I think the gobject property is unnecessary, using a conventional python class attribute instead is fine. I pushed it with this change as 5d018839 . Thanks!

comment:6 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.