Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#3533 closed defect (notabug)

Click with middle button

Reported by: humitos Owned by: erikos
Priority: Low Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

When you click on a link with the middle button the new page is loaded in the same tab instead opening a new one.

The default behaviour of Epiphany is "open the link in a new tab"

Change History (3)

comment:1 Changed 9 years ago by walter

Use the middle button is outside of the scope of the Sugar design guidelines (in the same category as double clicks).

comment:2 Changed 9 years ago by manuq

  • Resolution set to notabug
  • Status changed from new to closed

Yes, as Walter said, Sugar design is not intended to be used with a three buttons mouse, not even a mouse, only trackpad with two buttons.

From http://wiki.sugarlabs.org/go/Human_Interface_Guidelines/The_Sugar_Interface/Input_Systems#Trackpad

the laptops have two buttons positioned beneath the trackpad for input. The left button is the primary button with which elements of the interface are selected, pressed, or activated. The right button has secondary functionality. Typically, the right mouse button invokes contextual menus, the content of which pertains directly to the interface element the mouse is positioned over.

comment:3 Changed 9 years ago by walter

As we move towards touch support, et al., to add dependencies on more mouse buttons seems like a step in exactly the wrong direction.

Note: See TracTickets for help on using tickets.