Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#3530 closed defect (invalid)

Set current activity right after sharing/joining

Reported by: alsroot Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.94.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Right now, SetCurrentActivity() on org.laptop.Telepathy.BuddyInfo, can be setup only in Shell code. That will be more reliable if activity itself, after sharing/joining will do that. Especially, with telepathy-salut-0.6.0 and telepathy-glib-0.14.10, Shell never calls SetCurrentActivity().

Change History (3)

comment:1 Changed 9 years ago by alsroot

How it might be implemented:
git.sugarlabs.org/desktop/sugar-toolkit/commit/10f2fec9276e4b5c01d4741b105aa48e9b6673eb

comment:2 Changed 9 years ago by alsroot

  • Resolution set to invalid
  • Status changed from new to closed

Seems to be that setting current activity right after sharing is not reliable method, telepathy might fail with "Can't set an activity as current if you're not announcing it" error.

Also, I can't reproduce the origin issue with not setting current activity in Salut.

comment:3 Changed 8 years ago by dnarvaez

  • Component changed from sugar-toolkit to Sugar
Note: See TracTickets for help on using tickets.