Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3528 closed defect (fixed)

'Sugar' in the description given in My Settings > About My Computer should not be translated

Reported by: m_anish Owned by:
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Minor Keywords: dx3
Cc: Distribution/OS: OLPC
Bug Status: Assigned

Description

In the About My Computer section, the contents of 'info_text' in sugar/extensions/cpsection/view.py are gettexted.

"Sugar is the graphical user interface that you are....."

Viewing this in other languages, "Sugar" appears in translated form as well (eg: Azucar in spanish). I guess from that string, 'Sugar' should not be gettexed as that is a trademark (in a sense)

Change History (8)

comment:1 Changed 7 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Distribution/OS changed from Unspecified to OLPC
  • Milestone changed from Unspecified by Release Team to 0.98
  • Severity changed from Unspecified to Minor
  • Version changed from Unspecified to Git as of bugdate

Thanks for filing this one. Agreed about not translating Sugar. Because late in this cycle, moving to the next one. Patches how to achieve best translate the rest of the description but not Sugar and keep it nice for the translators welcome :)

comment:2 Changed 7 years ago by m_anish

  • Keywords dx3 added

Adding a keyword so I can track, and maybe write a patch :-)

comment:3 Changed 7 years ago by cjl

Please address this by adding a translator's comment to the string. I personally think it should be up to the individual languages whether they want to translate "Sugar" or not. Please file a bug against component=localization if there is a specific case you really want fixed.

comment:4 Changed 7 years ago by kartik.perisetla

Hi,

Resolved this issue. The link for patch: http://patchwork.sugarlabs.org/patch/1609/

comment:5 Changed 7 years ago by kartik.perisetla

Hi,

Here is the new patch with translator comment: http://patchwork.sugarlabs.org/patch/1610/

I hope this should work fine. :)

comment:7 Changed 7 years ago by erikos

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.