Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#351 closed defect (fixed)

AttributeError: 'module' object has no attribute 'evince_embed_init'

Reported by: gdesmott Owned by: morgs
Priority: Urgent Milestone:
Component: Read Version: 0.83.x
Severity: Major Keywords:
Cc: sayamindu, tomeu Distribution/OS: Unspecified
Bug Status: Assigned

Description

I just build a fresh sugar-jhbuild and got this when I try to run Read:

1234538630.997736 DEBUG root: datastore.get
1234538631.004944 DEBUG root: dbus_helpers.get_properties: ac40106e-65cd-46a2-b199-bca4379e2538
1234538631.015173 DEBUG root: * Act 53c115790ab8924ddc861102aab5cbd08f7e9870, mesh instance None, scope private
Traceback (most recent call last):

File "/home/cassidy/dev/sugar-jhbuild/install/bin/sugar-activity", line 21, in <module>

main.main()

File "/home/cassidy/dev/sugar-jhbuild/install/lib/python2.5/site-packages/sugar/activity/main.py", line 140, in main

create_activity_instance(activity_constructor, activity_handle)

File "/home/cassidy/dev/sugar-jhbuild/install/lib/python2.5/site-packages/sugar/activity/main.py", line 34, in create_activity_instance

activity = constructor(handle)

File "/home/cassidy/dev/sugar-jhbuild/install/share/sugar/activities/Lire.activity/readactivity.py", line 99, in init

evince.evince_embed_init()

AttributeError: 'module' object has no attribute 'evince_embed_init'

Change History (7)

comment:1 Changed 12 years ago by morgs

  • Cc sayamindu tomeu added

comment:2 follow-up: Changed 12 years ago by sayamindu

I think it is caused by the newer changes to evince. Commenting out evince.evince_embed_init() seems to work for me.

comment:3 in reply to: ↑ 2 Changed 12 years ago by tomeu

Replying to sayamindu:

I think it is caused by the newer changes to evince. Commenting out evince.evince_embed_init() seems to work for me.

Yeah, that's the right fix, sorry. Those initializations happen now when the module is imported.

comment:4 Changed 12 years ago by morgs

Fixed in git.

comment:5 Changed 12 years ago by morgs

  • Bug Status changed from Unconfimed to Assigned
  • Milestone changed from Unspecified by Release Team to 0.84
  • Priority changed from Unspecified by Maintainer to Urgent
  • Status changed from new to accepted
  • Version changed from Unspecified to 0.83.x

comment:6 Changed 12 years ago by tomeu

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:7 Changed 8 years ago by godiard

  • Milestone 0.84 deleted

Milestone 0.84 deleted

Note: See TracTickets for help on using tickets.