Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#3507 closed defect (fixed)

Browse: handle hiperlinks that open new windows

Reported by: manuq Owned by: manuq
Priority: Normal Milestone:
Component: Browse Version: Git as of bugdate
Severity: Unspecified Keywords: 12.1.0
Cc: erikos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Open the ones that are wanted in a new tab, like anchors with target="_blank" attribute. Test page:

http://dev.laptop.org/~erikos/wanted.html

And block the ones that do pop-up via javascript. Test page:

http://dev.laptop.org/~erikos/unwanted.html

Change History (5)

comment:1 Changed 9 years ago by manuq

Looking at webview signals "new-window-policy-decision-requested" and "create-web-view", and epiphany src/ephy-window.c which have callbacks for them.

comment:2 Changed 9 years ago by manuq

Patch sent to the mailing list. Both test cases pass.

Please pay attention to the patch comment regarding the "reason", shall we do any exception, that is, any new window request that should be blocked?

Here is a list of all the reasons:

http://webkitgtk.org/reference/webkitgtk/1.8.0/WebKitWebNavigationAction.html#WebKitWebNavigationReason

comment:3 Changed 9 years ago by manuq

We may also find useful this signals the WebView provides: script-alert, script-confirm, script-prompt. Maybe catch them and use our Sugar Alert instead of pop-ups?

comment:4 Changed 9 years ago by manuq

  • Resolution set to fixed
  • Status changed from new to closed

Pushed as 022ef0dd9791af51d7b9de38e813096f2ca60948 .

comment:5 Changed 8 years ago by dnarvaez

  • Milestone 0.96 deleted

Milestone 0.96 deleted

Note: See TracTickets for help on using tickets.