Opened 9 years ago

Closed 9 years ago

#3505 closed defect (fixed)

Paint should have Stop icon aligned to the right

Reported by: HoboPrimate Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Paint Version: 0.95.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

So that when you have bigger screen resolutions, like in this screenshot, the Stop button is still on the right..

Attachments (1)

Toolbar do Paint.png (11.1 KB) - added by HoboPrimate 9 years ago.
stop button is not right-aligned

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by HoboPrimate

stop button is not right-aligned

comment:1 follow-up: Changed 9 years ago by godiard

The problem is, in a xo with the normal resolution, if we add a separator, the stop button fall out of the toolbar.

comment:2 in reply to: ↑ 1 Changed 9 years ago by garycmartin

Replying to godiard:

The problem is, in a xo with the normal resolution, if we add a separator, the stop button fall out of the toolbar.

See Physics activity (and maybe some others) for the fix, you need to set the size of the separator so it does not eat some min amount of toolbar space (should be doing this in all activities):

separator = gtk.SeparatorToolItem()
separator.props.draw = False
separator.set_size_request(0, -1)
separator.set_expand(True)
toolbar_box.toolbar.insert(separator, -1)
separator.show()

comment:3 Changed 9 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Thanks Gary.

Pushed as 8beee4fa438697ca8a5b82cb1c38a862c5f893f4

Note: See TracTickets for help on using tickets.