Opened 7 years ago

Closed 7 years ago

#3503 closed defect (fixed)

Browse/wikipedia does not start - xo1.75 os8

Reported by: tonyforster Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Unspecified Keywords:
Cc: manuq Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Tried in os8 and wikipedia fails to start

File "/usr/lib/python2.7/site-packages/gi/types.py", line 261, in mro

raise TypeError('Cannot create a consistent method resolution '

TypeError: Cannot create a consistent method resolution order (MRO)
Exited with status 1, pid 917 data (None, <open file '<fdopen>', mode 'w' at 0xeb3b78>, '53eb62727f04ffebed7e5f4c65274154a7c8f4fb')

Change History (6)

comment:1 Changed 7 years ago by tonyforster

I have now seen the same error in Browse, changing the component to Browse

comment:2 Changed 7 years ago by tonyforster

  • Component changed from Wikipedia to Browse
  • Owner changed from godiard to erikos
  • Summary changed from wikipedia does not start - xo1.75 os8 to Browse/wikipedia does not start - xo1.75 os8

comment:3 Changed 7 years ago by manuq

  • Cc manuq added

comment:4 Changed 7 years ago by manuq

Hi Tony,

this should be due to #3497, can you check? I can use Wikipedia Activity with the workaround that is in comment 15 in that ticket.

Thanks for testing.

comment:5 Changed 7 years ago by tonyforster

Firstly an apology, my documentation is not good. I got the 'method resolution order' crash in 1 of 1 attempts starting Wikipedia Activity. I have no idea of its frequency of occurrence in the Wikipedia Activity. I also got it once in Browse, it is not the usual reason for Browse to crash, Browse crashes a lot for me but with different error messages.

Just now I tried Wikipedia EN Activity V33.5 OS9 XO-1.75, the mozilla plugins deleted as in #3497

In 3 tries, Wikipedia is slow to start and brings up a 'failed to start' notification
but does start, it has errors 'error root starting server database' and 'pallettewindow.py line 501 nonetype object has no attribute set_invoker.
When closed, the 'failed to start' notification remains

but in these 3 tries, I have not seen the 'method resolution order' bug which was the original subject of this ticket


comment:6 Changed 7 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Fixed long ago. If needed, reopen.

Note: See TracTickets for help on using tickets.