Opened 9 years ago

Closed 8 years ago

#3454 closed defect (fixed)

Clock should port to Cairo

Reported by: manuq Owned by: garycmartin
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Clock Version: Unspecified
Severity: Unspecified Keywords:
Cc: humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

This will be needed at some point for the move to GTK+3.

First patch attached. However, the text is not the right size in the XO and the patch should be updated.

Attachments (2)

0001-Port-to-Cairo.patch (13.8 KB) - added by manuq 9 years ago.
0001-Port-to-Cairo.2.patch (14.1 KB) - added by humitos 9 years ago.
New patch to make it applies in the latest git version

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by manuq

comment:1 Changed 9 years ago by garycmartin

Currently too slow on XO-1.75, especially with the nice clock (I have a simplified version of the clock.svg with no alpha effects that helps somewhat). Needs more performance work before I would land something like the move hands enhancement #1959

comment:2 Changed 9 years ago by manuq

Yes Gary, that is because of: https://dev.laptop.org/ticket/11654

Changed 9 years ago by humitos

New patch to make it applies in the latest git version

comment:3 Changed 9 years ago by humitos

  • Cc humitos added

comment:4 Changed 9 years ago by humitos

I tested this in XO 1.5 with os9 and works great: fast.

comment:5 Changed 8 years ago by manuq

  • Resolution set to fixed
  • Status changed from new to closed

Gary pushed it as 03349852 .

Note: See TracTickets for help on using tickets.