Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3428 closed defect (fixed)

Browse should set DPI for XO screen

Reported by: manuq Owned by: manuq
Priority: Unspecified by Maintainer Milestone:
Component: Browse Version: Git as of bugdate
Severity: Unspecified Keywords: 12.1.0 olpc-test-passed
Cc: erikos, dsd, tonyforster Distribution/OS: Unspecified
Bug Status: New

Description

The DPI should be changed for the screen in use. At least in the XO device, it should be changed to 134.

What we used to set in hulahop: http://kb.mozillazine.org/Layout.css.dpi

There is an attribute in webkitgtk+, device_dpi gobject property in viewport attributes, it is read-write, but changing it does have no effect in the viewer. Attaching test script.

Here is a blog post about what Safari does: http://www.webkit.org/blog/55/high-dpi-web-sites/

Attachments (1)

testdpi.py (1.5 KB) - added by manuq 7 years ago.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by manuq

comment:1 Changed 7 years ago by manuq

  • Cc dsd added

Chatted a bit in #webkitgtk+ . So, the device-dpi is only used for pages with the viewport metatag.

There is a ScreenHorizontalDPI and screenVerticalDPI in WebKit, but is not implemented in WebKitGTK+:

http://trac.webkit.org/browser/trunk/Source/WebCore/platform/gtk/PlatformScreenGtk.cpp#L63

They told me that most things in WebKitGTK+ stack hardcode 96dpi.

comment:2 Changed 7 years ago by manuq

  • Component changed from untriaged to telepathy
  • Keywords olpc-test-pending added
  • Resolution set to fixed
  • Status changed from new to closed

Not really setting the DPI in webkit, but changing the font sizes proved to give a very similar look. Pushed as 21b490da36fef775836de15f909717393b92f231 .

comment:3 Changed 7 years ago by tonyforster

  • Cc tonyforster added

comment:4 follow-up: Changed 7 years ago by tonyforster

Installed V135, still getting wrong font sizes on OS7

comment:5 in reply to: ↑ 4 Changed 7 years ago by manuq

Replying to tonyforster:

Installed V135, still getting wrong font sizes on OS7

With the new font size the pages will look similar as in previous Browse, but not exactly the same.

Do you see something like this in Wikipedia, for example?

http://dev.laptop.org/~manuq/browse_dpi/browse-8pt.png

Previous Browse looked like this in the same page:

http://dev.laptop.org/~manuq/browse_dpi/browse-11.3.1.png

Am I missing something? Or is there a page that looks too much different?

Thanks for testing!

comment:6 follow-up: Changed 7 years ago by tonyforster

The page looks a lot different, I am getting a much larger font

comment:7 in reply to: ↑ 6 Changed 7 years ago by manuq

Replying to tonyforster:

The page looks a lot different, I am getting a much larger font

Can you run this in a Python shell and paste the output?

from gi.repository import Gtk
gtk_settings = Gtk.Settings.get_default()
gtk_font_name = gtk_settings.get_property('gtk-font-name')
print gtk_font_name

Also a screenshot that shows the issue you see can be convenient. Thanks!

comment:8 follow-up: Changed 7 years ago by tonyforster

OS7 XO-1

Sorry, Browse behaviour has changed, now it crashes while starting or shortly after. The font size looks OK and the python script gives Sans 10

If I get a bad font size again, I will attempt to capture a screenshot and run the script

The crash during start is error dbus proxies:Introspect error
The crash shortly after is pallettewindows.py ln 499, none type object has no attribute set_invoker

Sorry I cannot attach proper crash logs because os7 will not mount a usb and has no working browser, the Gnome browser failed too

comment:9 in reply to: ↑ 8 Changed 7 years ago by erikos

  • Bug Status changed from Unconfirmed to New
  • Component changed from telepathy to Browse

Replying to tonyforster:

OS7 XO-1

Sorry, Browse behaviour has changed, now it crashes while starting or shortly after. The font size looks OK and the python script gives Sans 10

If I get a bad font size again, I will attempt to capture a screenshot and run the script

The crash during start is error dbus proxies:Introspect error
The crash shortly after is pallettewindows.py ln 499, none type object has no attribute set_invoker

Sorry I cannot attach proper crash logs because os7 will not mount a usb and has no working browser, the Gnome browser failed too

Hi Tony, you likely see #3401 on the XO-1. Will be fixed in the next build.

comment:10 Changed 7 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

Browse for the Spanish OLPC page looks like the attached screenshot in 12.1.0 os10/Browse-137.

There are other things such as both Wikipedia activities' homepage/list of articles which look noticeably different; but I don't know what we can do about that.

comment:11 Changed 6 years ago by dnarvaez

  • Milestone 0.96 deleted

Milestone 0.96 deleted

Note: See TracTickets for help on using tickets.