Opened 9 years ago

Closed 9 years ago

#3424 closed defect (fixed)

TA save SVG does not support rotated text

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Minor Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Later TA draws text at the turtle orientation but the SVG text is horizontal.

Low priority.

Change History (5)

comment:1 Changed 9 years ago by tonyforster

the fix is something like:

<text transform="rotate(90,699,367)" style="font-size:15.0px;fill:#ff0000;font-family:Sans">

<tspan x="699.0" y="367.0" style="font-size:15.0px;fill:#808000">text</tspan>

</text>

comment:2 Changed 9 years ago by walter

I think I need to bite the bullet and start handling SVG correctly. There is a nice facility in Cairo to make an SVG canvas (should help with #3423 as well). The only thing I haven't yet figured out is how to size the output at the end rather than at the beginning. (Right now, I generate a bounding box for the output but with the Cairo SVG canvas, you tell it the size before you render anything.) Stay tuned.

comment:3 Changed 9 years ago by walter

Should be fixed in v138

comment:4 Changed 9 years ago by tonyforster

Yes, works for me thanks.

comment:5 Changed 9 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in v139

Note: See TracTickets for help on using tickets.