Opened 9 years ago

Closed 9 years ago

#3422 closed defect (fixed)

TA Fill not writing to canvas if blocks not docked

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Single step the following, that is click on unconnected blocks

start fill
forward right
forward right
forward right
forward right
end fill

The fill is not fully drawn until you drag the mouse, alt tab, alt 1, start fill, etc.

Attachments (1)

IMG_0144.JPG.jpe (4.7 MB) - added by tonyforster 9 years ago.

Change History (5)

Changed 9 years ago by tonyforster

comment:1 Changed 9 years ago by walter

This seems to be related to a Cairo refresh issue. Will investigate a way to force the refresh to occur without having to resort to "drag the mouse, alt tab, alt 1, start fill, etc."

comment:2 Changed 9 years ago by walter

http://git.sugarlabs.org/turtleart/mainline/commit/90760b44fd2aca8815fdb8380b27bf45956bc2f0 seems to fix the problem. Patch will be incorporated into v138.

comment:3 Changed 9 years ago by tonyforster

seems ok with patch, thanks

comment:4 Changed 9 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.