Opened 9 years ago

Closed 8 years ago

#3421 closed defect (fixed)

Activities try to join not shared session

Reported by: alsroot Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.94.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Test case:

  • A and B have a jobject that was created with the same activity_id (e.g., after joining to A from B and saving jobjects on A and B);
  • from newly started A and B, A resumes his jobject;
  • it becomes shared;
  • A stops activity;
  • B resume his jobject;
  • activity tries to join (to absent A's session) and can't (scale is private)

The problem is being triggered by calling SetCurrentActivity for org.laptop.Telepathy.BuddyInfo in shell sources. Commenting out all these calls, "fixes" the problem.

Installed Telepathy:

  • telepathy-glib-0.14.10
  • telepathy-gabble-0.13.6
  • telepathy-mission-control-5.8.1

Change History (5)

comment:1 Changed 9 years ago by alsroot

  • Component changed from sugar to sugar-toolkit
  • Owner set to erikos

comment:3 Changed 9 years ago by alsroot

The SetCurrentActivity issue is different, #3425.

comment:4 Changed 8 years ago by dnarvaez

  • Component changed from sugar-toolkit to Sugar

comment:5 Changed 8 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.