Opened 9 years ago

Closed 9 years ago

#3415 closed defect (fixed)

New TA137 help

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

collapse a stack of blocks and then expand them, the hover help only sees the top and bottom blocks

Attachments (2)

Image clipping.png (16.0 KB) - added by tonyforster 9 years ago.
Turtle Art Activity help137.ta (326 bytes) - added by tonyforster 9 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by walter

I cannot reproduce this error. Could you check to see if there is any error in the log file? Also, could you please attach the project you are using for testing?

thanks

Changed 9 years ago by tonyforster

Changed 9 years ago by tonyforster

comment:2 Changed 9 years ago by tonyforster

nothing in the log
moving the blocks clears the problem
manually added cursor back to screenshot
the 3 left blocks hover as 'top of stack' but the pop from heap block to the right has hover help


Another help issue:
the Help (?) button seems to be only a hover point, that is clicking it doesnt seem to do anything. But if you change secondary toolbar, the hover you get at (?) doesnt refresh till you click it. It would be more consistent if its hover always displayed help for the current toolbar

comment:3 Changed 9 years ago by walter

Got it. Here is what is happening:

After you restore the collapsed stack, the top-of-stack block is ahead of the other blocks in the list, so it is found first when the cursor is over the rectangle that bounds the block. So I need to check to see if I am hitting a transparent area (which I do when testing for clicks).

comment:4 Changed 9 years ago by walter

Please try applying this patch to sprites.py. It seems to fix the bug but I wonder if it is not too slow?

http://git.sugarlabs.org/turtleart/mainline/commit/2b4ecb0cc7095f47fc944c54512e055c21537ab5

comment:5 Changed 9 years ago by tonyforster

Thanks
How do I download the patched file from git? Source Tree includes line numbers and formatting, download master as tar.gz gives a 1 byte file. The patch is a little long to hand edit, that may be what I have done before, can't remember.

comment:6 Changed 9 years ago by AlanJAS

clone the git of the Turtle, in a terminal, make:

git clone git://git.sugarlabs.org/turtleart/mainline.git

In the mainline folder there are all turtle's files..

comment:7 Changed 9 years ago by tonyforster

Thanks Walter and AlanJAS
The patch fixes the problem
No noticable delay on XO1.5 for the hoverhelp to appear. Is that what you mean by too slow? If it has slowed the execution of a stack then it might be too high a price to pay?

comment:8 Changed 9 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.