Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#3414 closed defect (duplicate)

Fix non-utf-8 ESSID handling

Reported by: martin.langhoff Owned by:
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Current Sugar assumes ESSID is utf-8. ESSIDs can be anything, and are sometimes byte sequences that are not valid as utf-8, triggering a crash. Details at http://dev.laptop.org/ticket/11698

Sugar's NM-client code must match NM's handling of ESSIDs for display, as discussed in http://developer.gnome.org/libnm-util/unstable/libnm-util-nm-utils.html#nm-utils-ssid-to-utf8

Change History (2)

comment:1 Changed 9 years ago by sascha_silbe

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #2023.

comment:2 Changed 8 years ago by dnarvaez

  • Milestone 0.96 deleted

Milestone 0.96 deleted

Note: See TracTickets for help on using tickets.