Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3411 closed defect (fixed)

Browse GTK3: Upload files - Browse opens file chooser instead of journal entry selector

Reported by: manuq Owned by: dsd
Priority: High Milestone:
Component: Browse Version: Git as of bugdate
Severity: Major Keywords: 12.1.0, upstream, patch, olpc-test-passed
Cc: erikos Distribution/OS: Unspecified
Bug Status: Assigned

Description

When an upload is requested, WebKitGTK+ opens the default GTK file chooser dialog, GtkFileChooser, but we need to open the Sugar object chooser instead.

WebKitGTK+ should provide an "upload-requested" signal, so we can handle it. This needs to be done in WebKitGTK+.

We already asked on the list for ideas [1]. There was some interest and a patch was done [2], but for WebKit2, and still not commited.

For the record, the html field that should send the signal is <form><input type=file> .

[1] https://lists.webkit.org/pipermail/webkit-gtk/2012-January/000894.html
[2] https://bugs.webkit.org/show_bug.cgi?id=78491

Attachments (1)

org.laptop.WebActivity-1.log (3.0 KB) - added by manuq 7 years ago.
dbus error while testing the webkitgtk test RPM

Download all attachments as: .zip

Change History (17)

comment:1 Changed 7 years ago by manuq

Gonzalo suggested csotts's preloading hack as a workaround. We can either add a workaround, or wait for WebKit2, as the fix is almost there for landing upstream.

comment:2 Changed 7 years ago by manuq

  • Priority changed from Unspecified by Maintainer to High

comment:3 Changed 7 years ago by manuq

  • Summary changed from Browse GTK3: Upload files to Browse GTK3: Upload files - Browse opens file chooser instead of journal entry selector

comment:4 Changed 7 years ago by manuq

'run-file-chooser' signal has landed in WebKitGTK+, but for WebKit2:

http://trac.webkit.org/changeset/115627

comment:5 Changed 7 years ago by manuq

  • Keywords upstream added

comment:6 Changed 7 years ago by manuq

dsd is doing great work upstream, backporting the filechooser signal to WebKit1. Tracked here: https://bugs.webkit.org/show_bug.cgi?id=87283

comment:7 Changed 7 years ago by dsd

  • Owner changed from manuq to dsd
  • Status changed from new to assigned

comment:8 Changed 7 years ago by dsd

Test RPMs with the patch included: http://dev.laptop.org/~dsd/20120604/

comment:9 Changed 7 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Severity changed from Unspecified to Major

Daniel, Manuel was saying you had as well a Browse patch already laying around for that? If so, can you please attach here?

comment:10 Changed 7 years ago by manuq

Daniel, I tested the RPM in XO-1.5 and patched Browse with the patch you sent to the list, I get an error in dbus.connection.py, log attached.

Changed 7 years ago by manuq

dbus error while testing the webkitgtk test RPM

comment:11 Changed 7 years ago by manuq

Forgot to mention the build, sorry. Is olpc latest build os12, XO-1.5 and Browse from git patched.

comment:12 Changed 7 years ago by dsd

Looks like you are running an old sugar-toolkit-gtk3

comment:13 Changed 7 years ago by manuq

Thanks, tested in os13. I've reviewed it and looks good. I will push with Simon's ACK.

comment:14 Changed 7 years ago by manuq

  • Keywords patch olpc-test-pending added
  • Resolution set to fixed
  • Status changed from assigned to closed

Pushed, is in Browse 140.

comment:15 Changed 7 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

The Sugar upload selector was tested with Gmail on XO-1.5 and XO-1.75 with 12.1.0 os16/Browse-140.

The filename chosen to upload from the Journal seemed to make sense.

comment:16 Changed 6 years ago by dnarvaez

  • Milestone 0.96 deleted

Milestone 0.96 deleted

Note: See TracTickets for help on using tickets.