Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#3410 closed defect (fixed)

Browse should enable plugins

Reported by: manuq Owned by: dsd
Priority: Unspecified by Maintainer Milestone:
Component: Browse Version: Git as of bugdate
Severity: Unspecified Keywords: 12.1.0, upstream
Cc: erikos Distribution/OS: OLPC
Bug Status: Unconfirmed

Description (last modified by manuq)

WebKitGTK+ settings [1] "enable-plugins" and "enable-java-applet" have default value TRUE, so plugins should work out of the box.

UPDATE: the following is false, see comment 4 below.

However, a simple test (attached) shows that this is not the case at least for the Python bindings. Plugins do not work by default, and setting "enable-plugins" to False makes Flash work. So this may be a bug in pygobject, inverting the booleans.

[1] http://webkitgtk.org/reference/webkitgtk/unstable/WebKitWebSettings.html#WebKitWebSettings--enable-java-applet

Attachments (3)

flash_embed.py (564 bytes) - added by manuq 11 years ago.
java_embed.py (523 bytes) - added by manuq 11 years ago.
org.laptop.WebActivity-1.log (4.6 KB) - added by manuq 11 years ago.
Log that shows the repeated output message displaying flash pages

Download all attachments as: .zip

Change History (22)

Changed 11 years ago by manuq

Changed 11 years ago by manuq

comment:1 follow-up: Changed 11 years ago by manuq

Gonzalo suggested csotts's preloading hack as a workaround. We can either add a workaround, or wait for WebKit2, as the fix is almost there for landing upstream.

comment:2 in reply to: ↑ 1 Changed 11 years ago by manuq

Sorry previous comment was for #3411.

comment:3 Changed 11 years ago by manuq

Also in Epiphany, if I uncheck "Enable plugins" in Preferences, only then I can see plugins.

Tested in F17 with webkitgtk3 1.8.0, and in F16 with webkitgtk3 1.6.1 .

comment:4 Changed 11 years ago by manuq

Sorry, I've been fooled by the html5 video in youtube, the interface mimics flash quite good now. The hypothesis of the inverted functionality in "enable-plugins" should be dropped.

The right page to test for Flash is: http://helpx.adobe.com/flash-player/kb/find-version-flash-player.html

comment:5 Changed 11 years ago by manuq

This piece of Python code will show the plugins that are available in the system for WebKit:

from gi.repository import WebKit
db = WebKit.WebPluginDatabase()
for p in db.get_plugins():
    print p.get_name(), p.get_path()

comment:6 Changed 11 years ago by manuq

  • Description modified (diff)

comment:7 Changed 11 years ago by manuq

os7: Flash is working out of the box with Gnash (has version 0.8.10).

Youtube test:

In XO-1.5 I see a black area in the video area. In XO-1.75 goes a bit
further: I can see the video preview with the play button in the
middle after the page loads. After clicking on it, fails because of
missing codecs. This is a gnash known issue. Two messages pop up
with errors for audio and video codec.

Adobe "find flash player version" test:
http://helpx.adobe.com/flash-player/kb/find-version-flash-player.html

Works, I can pause/play, toggle fullscreen.

http://www.chemgapedia.de/vsengine/info/en/help/requirements/flash.html

Also works the animation of the spheres. The video test fails for the
same reasons as youtube video.

Browse In XO-1.75 is having sporadic crashes.

comment:8 Changed 11 years ago by manuq

Tested IcedTea in XO-1.5 and XO-1.75. If I go to a page with a Java
plugin, I can't see it, a little blue cage is displayed instead. Then
if I change to another page, crash.

Tested in my devel machine running F16. Works fine in Firefox.
Doesn't work in Epiphany, a little blue cage is displayed. No crash
of the browser.

Then I tried to install sun java, downloaded the rpm.bin and executed it,
after that I did the symlink but java is not listed in the plugins for
firefox. Maybe I should remove icedtea entirely instead of just
moving the .so binary out of /usr/lib/mozilla/plugins .

comment:9 Changed 11 years ago by manuq

Here's the bug reported for IcedTea in Epiphany at RedHat bug tracker:

https://bugzilla.redhat.com/show_bug.cgi?id=742584

comment:10 Changed 11 years ago by manuq

Trying adobe flash player... unsuccessfully.

In olpc build os8 with XO-1.5 .

Went to the adobe page, http://get.adobe.com/flashplayer . It guess I'm using chrome or open source chromium browser. I downloaded adobe-release-i386-1.0-1.noarch.rpm and installed it. This installs a repo in /etc/yum.repos.d/adobe-linux-i386.repo .

I then installed flash-plugin (18M) using yum install flash-plugin . This replaces gnash, overriding the symlink in /usr/lib/mozilla/plugins/libflashplayer.so that now points to

/usr/lib/flash-plugin/libflashplayer.so . The plugin database test in comment 5 shows it, I removed libtotem-vegas-plugin.so (which also claims to provide Shokwave Flash) just in case.

Then opened Browse and tried the same pages as in the gnash test in comment 7 but they don't show the flash embeds, the blue box with the ? sign is displayed instead (as with java in IcedTea.

Same happens inside Epiphany.

comment:11 Changed 11 years ago by manuq

Tested Sun Java for i386 and ARM, it works in current Browse.

For i386

I followed this instructions: http://www.freetechie.com/blog/installing-sun-java-on-fedora-12/

I downloaded jre-7u4-linux-i586.rpm in XO-1.5 os8. Installed the
package, did the symlinks specified in the instructions with the
"alternatives" command.

Only had to change the command for libnpjp2.so, seems a mistake in the
instructions for i386. The command to use is:

alternatives --install /usr/lib/mozilla/plugins/libnpjp2.so
libnpjp2.so  /usr/java/jre1.6.0_31/lib/i386/libnpjp2.so 20000

For ARM

I tried in XO-1.75 os8:

  • Java SE for Embedded 7
  • ARMv7 Linux - Headful
  • EABI, Hard Float (VFP), Little Endian

I uncompressed the tarball and did this symlinks:

sudo ln -s /home/olpc/ejre1.7.0_04/lib/arm/libnpjp2.so /usr/lib/mozilla/plugins/
sudo ln -s /home/olpc/ejre1.7.0_04/bin/java /usr/bin/java

comment:12 Changed 11 years ago by manuq

  • Keywords upstream added

comment:14 Changed 11 years ago by dsd

  • Owner changed from manuq to dsd
  • Status changed from new to assigned

Fixed upstream. Test RPMs with the patch included: http://dev.laptop.org/~dsd/20120604/

Works with nspluginwrapper.

comment:15 Changed 11 years ago by manuq

Installed the test RPM, nspluginwrapper via yum, and adobe flash in XO-1.5 olpc build os12. Then opened Browse and navigated to http://helpx.adobe.com/flash-player/kb/find-version-flash-player.html . Flash does not work, the area of the embed is filled grey. The logs shows this line several times:

** Message: console message:  @0: event.layerX and event.layerY are broken and deprecated in WebKit. They will be removed from the engine in the near future.

Patch attached.

Changed 11 years ago by manuq

Log that shows the repeated output message displaying flash pages

comment:16 Changed 11 years ago by dsd

Yes, you have to do some extra steps. You can find them in the adobe_flash module in olpc-os-builder.

comment:17 Changed 11 years ago by dsd

If you want to test, best way is to build your own OS image with adobe_flash module included.

comment:18 Changed 10 years ago by dsd

  • Resolution set to fixed
  • Status changed from assigned to closed

This is fixed upstream and in OLPC OS 12.1.0.

comment:19 Changed 9 years ago by dnarvaez

  • Milestone 0.96 deleted

Milestone 0.96 deleted

Note: See TracTickets for help on using tickets.