Opened 9 years ago

Closed 9 years ago

#3372 closed defect (fixed)

"make" fails for sugar-toolkit-gtk3

Reported by: humitos Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: sugar-jhbuild Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Debian
Bug Status: Unconfirmed

Description

I'm getting this error when I run "make" inside the "sugar-toolkit-gtk3"

[humitos] [/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3]$ make
Making all in bin
make[1]: se ingresa al directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/bin'
make[1]: No se hace nada para `all'.
make[1]: se sale del directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/bin'
Making all in src
make[1]: se ingresa al directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src'
Making all in sugar3
make[2]: se ingresa al directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3'
make  all-recursive
make[3]: se ingresa al directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3'
Making all in activity
make[4]: se ingresa al directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3/activity'
make[4]: No se hace nada para `all'.
make[4]: se sale del directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3/activity'
Making all in bundle
make[4]: se ingresa al directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3/bundle'
make[4]: No se hace nada para `all'.
make[4]: se sale del directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3/bundle'
Making all in graphics
make[4]: se ingresa al directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3/graphics'
make[4]: No se hace nada para `all'.
make[4]: se sale del directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3/graphics'
Making all in presence
make[4]: se ingresa al directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3/presence'
make[4]: No se hace nada para `all'.
make[4]: se sale del directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3/presence'
Making all in datastore
make[4]: se ingresa al directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3/datastore'
make[4]: No se hace nada para `all'.
make[4]: se sale del directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3/datastore'
Making all in dispatch
make[4]: se ingresa al directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3/dispatch'
make[4]: No se hace nada para `all'.
make[4]: se sale del directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3/dispatch'
make[4]: se ingresa al directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3'
make[4]: *** No hay ninguna regla para construir el objetivo `SugarExt-1.0.gir', necesario para `all-am'.  Alto.
make[4]: se sale del directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3'
make[3]: *** [all-recursive] Error 1
make[3]: se sale del directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3'
make[2]: *** [all] Error 2
make[2]: se sale del directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src/sugar3'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3/src'
make: *** [all-recursive] Error 1
[humitos] [/srv/sugar-jhbuild-new/source/sugar-toolkit-gtk3]$

Change History (2)

comment:1 Changed 9 years ago by humitos

I think this is happening because "gdk-3.0" package is missing.

comment:2 Changed 9 years ago by sascha_silbe

  • Resolution set to fixed
  • Status changed from new to closed

Caused by missing dependency on libgirepository1.0-dev (fixed in 47f2a40). Diagnosis was harder than necessary because sugar-toolkit-gtk3 detected that some part of gobject-introspection was missing and omitted parts of the build logic instead of failing hard (patch submitted for review).

Note: See TracTickets for help on using tickets.