Opened 8 years ago

Closed 7 years ago

#3354 closed defect (fixed)

Terminal: use the same style in the tabs as Browse

Reported by: manuq Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Terminal Version: Git as of bugdate
Severity: Unspecified Keywords: easy-hacks, screenshot
Cc: humitos, manuq, danielfrancis, RafaelOrtiz Distribution/OS: Unspecified
Bug Status: Assigned

Description


Attachments (2)

51.png (15.7 KB) - added by humitos 8 years ago.
Tab size at startup
08.png (15.9 KB) - added by humitos 8 years ago.
Tab size after opening and closing many tabs

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by humitos

  • Cc humitos manuq danielfrancis RafaelOrtiz added
  • Keywords screenshot added

This tabs style bar is already applied but it has a bug: when there is only one tab the size of it is not the same at start up than after open and close many tabs

Steps to reproduce it

  1. Open Terminal (Gtk3 Branch)
  2. Open many tabs
  3. Close all the tabs just opened

Issue

The size of the tab is not the same than at start up

Expected behaviour

Show the start up tab size equal than the last one (the smaller version -Browse has that width for it)

Changed 8 years ago by humitos

Tab size at startup

Changed 8 years ago by humitos

Tab size after opening and closing many tabs

comment:2 follow-up: Changed 8 years ago by danielfrancis

The Terminal tabs are programmed to be expanded to the maximum possible size, unlike browse.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 8 years ago by manuq

Replying to danielfrancis:

The Terminal tabs are programmed to be expanded to the maximum possible size, unlike browse.

Yes! And that's ok, because we are probably going to do the same in Browse, see #3560 . So I proposed Daniel and Agus to do it like this.

Daniel, what humitos points is that if you open a new tab, then close it, you get a tab width which is half the available space. Should take all the space.

Also, would be good to set a minimun size, let's ensure 8 tabs on the screen. Check browser.py in Browse code, look for the tab_min_size variable ;)

Great job!

comment:4 in reply to: ↑ 3 Changed 8 years ago by danielfrancis

Replying to manuq:

Replying to danielfrancis:

The Terminal tabs are programmed to be expanded to the maximum possible size, unlike browse.

Yes! And that's ok, because we are probably going to do the same in Browse, see #3560 . So I proposed Daniel and Agus to do it like this.

Daniel, what humitos points is that if you open a new tab, then close it, you get a tab width which is half the available space. Should take all the space.

Yes, this is the little bug, I was only correcting the expected behavior Humitos told.

Also, would be good to set a minimun size, let's ensure 8 tabs on the screen. Check browser.py in Browse code, look for the tab_min_size variable ;)

I'll take a look in the sources of Terminal and Browse, the terminal tabs have already a minimum size for the tabs automatically, try to open a lot of tabs, but there's pending to solve this bug.

comment:5 follow-up: Changed 7 years ago by danielfrancis

  • Bug Status changed from Unconfirmed to Resolved

Solved and pushed to repository as fb2d170f73b404e78ffd86d4777ab6edeb470cae
Please, test it. If that's all, we can close this ticket.

comment:6 in reply to: ↑ 5 ; follow-up: Changed 7 years ago by manuq

  • Bug Status changed from Resolved to Assigned

Replying to danielfrancis:

Solved and pushed to repository as fb2d170f73b404e78ffd86d4777ab6edeb470cae
Please, test it. If that's all, we can close this ticket.

I still see the the issues we discussed by email.

First tab should be half screen, it is getting all the size:

http://dev.laptop.org/~manuq/terminal-1st_tab.png

Second tab looks ok:

http://dev.laptop.org/~manuq/terminal-2nd_tab.png

Closing second tab makes 1st one look ok:

http://dev.laptop.org/~manuq/terminal-1st_tab_again.png

If you add more tabs, unused space starts to appear between the tabs and the + button:

http://dev.laptop.org/~manuq/terminal-many_tabs.png

comment:7 in reply to: ↑ 6 Changed 7 years ago by danielfrancis

Replying to manuq:

I still see the the issues we discussed by email.

I only can say... Please, check at your installed version.

First tab should be half screen, it is getting all the size:

Line 90 to 96 in widgets.py are for solve that:
http://git.sugarlabs.org/terminal/mainline/blobs/gtk3/widgets.py#line90

http://dev.laptop.org/~manuq/terminal-1st_tab.png

I don't attach a picture because I haven't got a similar service as you and I think pictures cannot be attached here.

If you add more tabs, unused space starts to appear between the tabs and the + button

This line layouts all the tabs perfectly:
http://git.sugarlabs.org/terminal/mainline/blobs/gtk3/widgets.py#line102

comment:8 Changed 7 years ago by manuq

  • Resolution set to fixed
  • Status changed from new to closed

Oh sorry Daniel, looks like I was having an issue in my dev environment. They look great :)

Note: See TracTickets for help on using tickets.