Opened 7 years ago

Closed 7 years ago

#3340 closed defect (duplicate)

Permission denied exception while launching the Date&Time Control Panel menu

Reported by: m_anish Owned by: ajay_garg
Priority: Immediate Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Blocker Keywords: dx3
Cc: jerryV Distribution/OS: Dextrose
Bug Status: Assigned

Description (last modified by m_anish)

==Testcase 1==

  • Open the My Settings panel
  • Open the Date and Time settings panel
  • Exception (pasted below) in logs

==Testcase 2==

  • Open the My Settings panel
  • Open the Date and Time settings panel
  • Enter a value in the text entry field (for a ntp server address)
  • Click Accept
  • Permission denied exception

Probably, some group permissions need to be set in-order to make sure this functions correctly.

==Log==

1329988150.166674 ERROR ControlPanel - TimeZone: Error removing file.
Traceback (most recent call last):
  File "/usr/share/sugar/extensions/cpsection/datetime/model.py", line 126, in set_ntp_servers
    os.remove(NTP_SERVER_CONFIG_FILENAME)
OSError: [Errno 13] Permiso denegado: '/etc/ntp/step-tickers'
1329988158.235244 ERROR ControlPanel - TimeZone: Error removing file.
Traceback (most recent call last):
  File "/usr/share/sugar/extensions/cpsection/datetime/model.py", line 126, in set_ntp_servers
    os.remove(NTP_SERVER_CONFIG_FILENAME)
OSError: [Errno 13] Permiso denegado: '/etc/ntp/step-tickers'

Change History (2)

comment:1 Changed 7 years ago by m_anish

  • Description modified (diff)

comment:2 Changed 7 years ago by m_anish

  • Resolution set to duplicate
  • Status changed from new to closed

oops! dupe of #3339

closing!

Note: See TracTickets for help on using tickets.