Opened 7 years ago

Closed 6 years ago

#3317 closed enhancement (fixed)

Multi-selection operations (Copy and Erase)

Reported by: ajay_garg Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Attachments (3)

0001-sugar-sl-3317.patch (50.4 KB) - added by ajay_garg 7 years ago.
0001-sugar-toolkit-sl-3317.patch (1.5 KB) - added by ajay_garg 7 years ago.
0001-sugar-artwork-sl-3317.patch (7.5 KB) - added by ajay_garg 7 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by ajay_garg

Attaching the patches ::

(Note that "0001-sugar-sl-3317.patch" patch must be applied, after applying the patch at http://patchwork.sugarlabs.org/patch/1157/

Changed 7 years ago by ajay_garg

Changed 7 years ago by ajay_garg

Changed 7 years ago by ajay_garg

comment:3 Changed 7 years ago by ajay_garg

Patch v5 at
http://patchwork.sugarlabs.org/patch/1183/

Commit Link
http://git.sugarlabs.org/dextrose/mainline/commit/e2679fdfaec3d8af23aff2a37e057c3dd087d01d

Changes of version-5 over version-4


  1. Temporary workaround for the dbus-timeout issue. Enclosed metadata-copy, and metadata-write operations in a Try/Catch block, so that ANY exceptions/errors are caught; while the operation continues to proceeed. Thanks Anish for catching that.

comment:4 Changed 7 years ago by ajay_garg

Patch v6 at
http://patchwork.sugarlabs.org/patch/1185/

Commit Link
http://git.sugarlabs.org/dextrose/mainline/commit/42912f86cb88173d6574af0d8290a93de5ece979

Changes of version-6 over version-5


  1. Any journal-entries with ".xo" extension, were being installed even though it was only being selected/deselected (in both single- and double- mode). Fixed it. Thanks Anish and Sascha.

comment:6 Changed 7 years ago by ajay_garg

Changes of version-7 over version-6


  1. Select-all/Select-None actions have been made in-memory. This
serves the following two purposes
(i) Now, the select/deselect actions are not persisted to disk. (ii) Major speedup in select/deselect operations.

The solution was figured out by Anish; I just did the mechanics of
coding, that's it ;)

Also, thanks to Sascha.

comment:7 Changed 7 years ago by ajay_garg

Patch v8 at
http://patchwork.sugarlabs.org/patch/1205/

Commit Link
http://git.sugarlabs.org/dextrose/mainline/commit/22ee61af567acba7ee5fee1f656804a19e561684

Changes of version-8 over version-7


  1. A minor change in "select_set_data_cb(self, column, cell, tree_model, tree_iter)" in class "listview.py".

This UI callback function may be called, when the model is
still not ready.
Since this function just affects the checkbox (only a UI
change), so if the model is still not ready, it is safe to
return at this point.

Thanks to Anish for catching that.

comment:8 Changed 6 years ago by dnarvaez

  • Component changed from untriaged to sugar
  • Owner set to erikos

Temptatively assigning to sugar.

comment:9 Changed 6 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.