Opened 11 years ago

Closed 10 years ago

Last modified 7 years ago

#330 closed defect (fixed)

Several Access Points with the same essid

Reported by: erikos Owned by: erikos
Priority: High Milestone:
Component: Sugar Version: 0.83.x
Severity: Major Keywords: r?
Cc: sascha_silbe, dsd Distribution/OS: Unspecified
Bug Status: Needinfo

Description

Lets call it the conference conditions - one essid and several Access Points. The question is how I limit the displaying best.

Attachments (3)

0001-Group-access-points-by-network-330.patch (20.7 KB) - added by dsd 10 years ago.
0001-Group-access-points-by-network-330-v2.patch (23.2 KB) - added by dsd 10 years ago.
updated patch
0001-Group-access-points-by-network-330-v2.2.patch (24.4 KB) - added by dsd 10 years ago.
updated after review

Download all attachments as: .zip

Change History (13)

comment:1 Changed 11 years ago by tomeu

  • Bug Status changed from Unconfimed to Needinfo
  • Milestone changed from 0.84 to 0.86

I'm guessing we still need to discuss how to solve this and will involve UI additions. Moving to 0.86.

comment:2 Changed 11 years ago by sascha_silbe

  • Cc sascha_silbe added

erikos, can you explain a bit more what you're talking about? I've noticed (and complained about to tomeu) that while Build-801 (Sugar 0.82.1 + NetworkManager 0.6) shows one entry per ESSID, sugar-jhbuild on DebXo with NetworkManager 0.7 shows each single AP, so the whole screen is cluttered when I'm at university. This might be exactly what this bug is about, or maybe not.

comment:3 Changed 11 years ago by erikos

Yes, sounds like. I guess the scenario you are seeing is: several access points - and one essid (Roaming). Currently we show each access point in the mesh view.

comment:4 Changed 11 years ago by sascha_silbe

Exactly. Since 0.82.1 only showed a single entry per ESSID, I'd almost call it a regression.
How about just reverting to the old behaviour of showing ESSIDs instead of APs? Is there any value in listing each AP separately?

comment:5 Changed 10 years ago by sascha_silbe

  • Cc dsd added
  • Summary changed from Severall Access Points with the same essid to Several Access Points with the same essid

From duplicate bug #1552:

reproduced on 0.84 and 0.86 and at http://dev.laptop.org/ticket/9645 :

My home network has 2 APs on the same physical network. They have the same SSID and security settings for obvious reasons. sugar-0.82 showed a single entry for this network, sugar-0.84+ shows one circle per AP.

GNOME NM applet does not have this problem, because it has logic to only show 1 menu entry. see get_menu_item_for_ap() in applet-device-wifi.c. Equivalent logic is missing from sugar.

comment:6 Changed 10 years ago by dsd

  • Keywords r? added

Please review attached patch. It fixes the issue and has been tested on sugar-jhbuild

comment:7 Changed 10 years ago by dsd

review comments from IRC:

  • calculate max strength with max([0] + [ap.strength for ap in self._access_points.values()])
  • move AccessPoint class into model
  • remove duplicated dbus async request handlers and fix logging.debug() of errors
  • 2 blank lines between classes
  • need to add logic for deleting old network if its only AP changes identity
  • hoping for comments from Simon too

Changed 10 years ago by dsd

updated patch

comment:8 Changed 10 years ago by dsd

thanks for reviewing, here is an updated version

Changed 10 years ago by dsd

updated after review

comment:9 Changed 10 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

committed to master, thanks for reviewing

comment:10 Changed 7 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.