Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3270 closed enhancement (fixed)

Avoid using gconf for getting proxy settings

Reported by: alsroot Owned by: alsroot
Priority: Normal Milestone: Unspecified
Component: sugar-server-kit Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by alsroot)

The reason is using only standard way to get information about proxy settings. Also gconf might be fragile (at least for some versions on fc9(11?)) for getting user gconf values from root user.

This implementation reads http_proxy envar from the caller process. That should work fine in Sugar Shell 0.95+ since it exports this envar even if proxy was set in gconf.

Change History (3)

comment:1 Changed 7 years ago by alsroot

  • Description modified (diff)

comment:2 Changed 7 years ago by alsroot

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 7 years ago by alsroot

For now, the http_proxy usage behaviour is simple, whatever {{Code|sugar-client* update}} command you call, for proxy related setting it uses the {{Code|http_proxy}} environment variable from the caller process. If {{Code|sugar-client}} was called with {{Coded}} argument by root user, it will be {{Code|http_proxy}} from root user process; if {{Code|sugar-client}} was called from non-root user, it will be {{Code|http_proxy}} from non-root user process.
Note: See TracTickets for help on using tickets.