Opened 8 years ago

Closed 8 years ago

#3242 closed defect (fixed)

Need default url for updater - patch0048

Reported by: JerryV Owned by: m_anish
Priority: High Milestone: Unspecified
Component: Sugar Version: 0.94.x
Severity: Major Keywords: dx3
Cc: dsd, sridhar, sascha_silbe Distribution/OS: Dextrose
Bug Status: Resolved

Description

With the switch to microformat in DX3 you need to pre-populate ~/.gconf/desktop/sugar/updater_url with a url for the webpage. Otherwise software update in CP just hangs with fetching update information. Also of note is sugar-update-control has the ability to alter the url. Not sure if your able to do that with this version yet.

Attachments (4)

micro-shell.log (15.2 KB) - added by JerryV 8 years ago.
shell.log
micro.diff (403 bytes) - added by JerryV 8 years ago.
diff of change
after-shell.log (27.0 KB) - added by JerryV 8 years ago.
shell.log of responding updater.
invert.diff (633 bytes) - added by JerryV 8 years ago.
diff for model.py

Download all attachments as: .zip

Change History (16)

Changed 8 years ago by JerryV

shell.log

comment:1 Changed 8 years ago by JerryV

After setting gconf value to: http://wiki.laptop.org/go/Activities/OLPCAU/11.3.1 the activity-updater crashes due to the use of dotted-activities, micro-shell.log attached.

comment:2 Changed 8 years ago by JerryV

Changed the value from a number to a string, and it works. Patch attached

Changed 8 years ago by JerryV

diff of change

Changed 8 years ago by JerryV

shell.log of responding updater.

comment:3 Changed 8 years ago by JerryV

The problem now becomes it appears that older activities on the above wiki will overwrite higher versions of the same activities already installed. On a plus note new activities are not selected but default.

comment:4 Changed 8 years ago by JerryV

The fix for the inverted behaviour

Changed 8 years ago by JerryV

diff for model.py

comment:5 Changed 8 years ago by JerryV

Think we can get this into sugar 95.3?

comment:6 follow-up: Changed 8 years ago by JerryV

Think there should be a way to alter the url like sugar-update-control has, as not having to mess with gconftool-2 to alter the url.

comment:7 Changed 8 years ago by JerryV

  • Cc dsd sridhar added

cc'ing dsd, sridhar. Think if this gets resolved, sugar-update-control can go away for sugar 0.96.

comment:8 Changed 8 years ago by m_anish

  • Cc sascha_silbe added
  • Distribution/OS changed from Unspecified to Dextrose

Adding Sascha to include diffs attached to this ticket to modify the appropriate patch in patchset.

About changing the url, until such functionality is provided, the gconf needs to be pre-populated within the dx3 patchset.

Thanks for the ticket!

comment:9 in reply to: ↑ 6 Changed 8 years ago by m_anish

Replying to JerryV:

Think there should be a way to alter the url like sugar-update-control has, as not having to mess with gconftool-2 to alter the url.

Opened ticket #3247 to track this.

comment:10 Changed 8 years ago by m_anish

  • Bug Status changed from Unconfirmed to Assigned
  • Owner set to m_anish
  • Priority changed from Unspecified by Maintainer to Urgent
  • Status changed from new to assigned

comment:11 Changed 8 years ago by m_anish

  • Priority changed from Urgent to Immediate

comment:12 Changed 8 years ago by m_anish

  • Bug Status changed from Assigned to Resolved
  • Priority changed from Immediate to High
  • Resolution set to fixed
  • Severity changed from Blocker to Major
  • Status changed from assigned to closed

Dextrose-3 is no longer using its own microformat updater for the time being, reducing the severity:priority of this bug. (We'd still want it to be included in the longer run, or in places where we don't use proxy networks).

In any case, this bug is fixed, since the default url for the updater _is_ now set correctly.

Note: See TracTickets for help on using tickets.