Opened 9 years ago

Closed 8 years ago

#3221 closed enhancement (fixed)

GTK3 sugar port should include ATK/at-spi accessibility support

Reported by: greenfeld Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

With the removal of Hippocanvas, we should make sure that Sugar properly exposes and incorporates the ATK accessibility API, or something else which goes back to at-spi.

For example, it may be desirable or necessary in activities to provide a more descriptive accessibility hint of what a button does. And due to layout issues it may be necessary to describe what an icon does, because it looks like it has no tooltip to the underlying system.

We also should include a control in Sugar's control panel to enable/disable the accessibility API similar to what GNOME does.

Not only will this allow screen readers, etc., to use Sugar, but it will also make automated testing of Sugar easier. If we choose to do this after the GTK3 port, retrofitting Activities may be harder than encouraging them to do it as part of it.

The GNOME Accessibility Developers Guide can be found at http://developer.gnome.org/accessibility-devel-guide/stable/

Change History (2)

comment:1 Changed 9 years ago by dnarvaez

I think all you need to enable at-spi these days is to set in the env

GTK_MODULES=gail:atk-bridge

It should be pretty easy to add a control panel preference to control it.

comment:2 Changed 8 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from new to closed

This works out of the box these days, nothing to do on the sugar side.

Note: See TracTickets for help on using tickets.