Opened 8 years ago

Closed 8 years ago

#3220 closed defect (notsugar)

invalid-lc-messages-dir and incorrect-fsf-address

Reported by: callkalpa Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Paths Version: Unspecified
Severity: Unspecified Keywords:
Cc: walter@…, cjl Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

I was trying to package Paths for fedora and got the following errors from rpmlint on the rpm file

sugar-paths.noarch: W: non-standard-group Sugar/Activities
sugar-paths.noarch: E: incorrect-fsf-address /usr/share/sugar/activities/Paths.activity/constants.py
sugar-paths.noarch: E: invalid-lc-messages-dir /usr/share/locale/cpp/LC_MESSAGES/org.sugarlabs.PathsActivity.mo
sugar-paths.noarch: E: invalid-lc-messages-dir /usr/share/locale/nah/LC_MESSAGES/org.sugarlabs.PathsActivity.mo
sugar-paths.noarch: E: invalid-lc-messages-dir /usr/share/locale/son/LC_MESSAGES/org.sugarlabs.PathsActivity.mo
sugar-paths.noarch: E: incorrect-locale-subdir /usr/share/locale/templates/LC_MESSAGES/org.sugarlabs.PathsActivity.mo
sugar-paths.noarch: E: invalid-lc-messages-dir /usr/share/locale/templates/LC_MESSAGES/org.sugarlabs.PathsActivity.mo
sugar-paths.noarch: E: invalid-lc-messages-dir /usr/share/locale/ton/LC_MESSAGES/org.sugarlabs.PathsActivity.mo

Change History (7)

comment:1 Changed 8 years ago by walter

  • Cc cjl added

Again, we have a situation where by there are languages which are not yet supported by Fedora. I think the short-term solution is to remove these languages.

comment:2 Changed 8 years ago by cjl

I completely agree with that solution. It is unfortunate that there are not upstream efforts in all of our languages, but we are often trying to be the first native language computing experience in under-served areas, so we will run into that. I think handling it pragmatically is the best way to go. Sorry for the inconvenience to the packager and I greatly appreciate the packaging effort.

I suspect that in most of these cases there are no translated strings in the PO file anyway.

We are working to develop and upstream new glibc locales where there is an active effort, but I would not want to take down any languages from Pootle, I'd rather try to recruit localizers.

I would say, delete these PO files in the local environment prior to packaging and then close this ticket.

comment:3 Changed 8 years ago by callkalpa

still

sugar-paths.noarch: E: incorrect-fsf-address /usr/share/sugar/activities/Paths.activity/constants.py

is there

comment:4 Changed 8 years ago by cjl

Walter, I'm not sure I can explain the issue in callkalpa's last comment, do you have an answer?

comment:5 Changed 8 years ago by callkalpa

cjl, it's nothing to do with localization. the fsf address is wrong in one of the files. walter will issue a patch or a new release with the issue fixed.

comment:6 Changed 8 years ago by cjl

Ok, glad to hear it's not another L10n issue that's tripped you up

:-)

Thank you for the packaging you are doing. It is great that these activities will reach a wider audience through your efforts, it is much the same way I feel about what I try to do by working on L10n, it is all about reaching the largest possible audience and leveraging the existing work as much as possible.

comment:7 Changed 8 years ago by walter

  • Resolution set to notsugar
  • Status changed from new to closed

Since this is really not a bug specific to Paths, I will close the ticket.

Note: See TracTickets for help on using tickets.