Opened 9 years ago

Closed 9 years ago

#3208 closed enhancement (fixed)

SVG images are clipped

Reported by: godiard Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Wikipedia Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

In many cases, like in the image in the page "Planet" section "Orbit", a svg image is clipped, because there are not a easy way to scale a svg image to a fixed size using object. In the same page, in the section "Solar system" every planet have a svg with the symbol, and are clipped too.

I have tried not set the width in the object, but we can't display the svg without setting a width because for example in the "Plant" page there are a lot of svg files and render at huge sizes.

Now, in the pages in the online wikipedia, are using a thumbnail in png format. Rendered a small sizes, are lighther than the svg files in more cases.

We can change our logic to use thumbnails to svg too.

Example:

http://en.wikipedia.org/wiki/File:TheKuiperBelt_Orbits_Pluto_Ecliptic.svg

http://upload.wikimedia.org/wikipedia/commons/thumb/1/1d/TheKuiperBelt_Orbits_Pluto_Ecliptic.svg/220px-TheKuiperBelt_Orbits_Pluto_Ecliptic.svg.png

A posible patch is attached, need more testing.

Attachments (1)

use-thumbnails-in-svg.patch (928 bytes) - added by godiard 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by godiard

comment:2 Changed 9 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Thanks, pushed 669f12ffd9ddd42ed6f1c43c0331c9db8ff46b0e

Note: See TracTickets for help on using tickets.