Opened 9 years ago

Closed 7 years ago

#3207 closed enhancement (fixed)

save multiple timestamps in Journal

Reported by: walter Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: godiard Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

In discussing the Journal in the learning chat, it was asked if it was possible to know how many times a child used an activity. Since we only store the time of most recent use (and we don't have versioning) the answer is no. But why not store an array of timestamps, or at least a tag that is updated with a count? Seems like a simple enough change.

Change History (4)

comment:1 Changed 9 years ago by garycmartin

This would be great, the more automated metadata we can add the better. This particular data would allow the potential to sortJournal entries by most frequent use, and/or help an Achievemnt activity provide a more fun/friendly UI overview of accomplishments (for both the child and teacher).

comment:2 Changed 9 years ago by godiard

  • Cc godiard added

comment:3 Changed 8 years ago by dnarvaez

  • Component changed from journal to sugar

comment:4 Changed 7 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.