Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#3205 closed defect (fixed)

Search entry not associated with activities list view and Journal

Reported by: godiard Owned by: godiard
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords: olpc-test-passed
Cc: erikos Distribution/OS: Unspecified
Bug Status: New

Description

If the user type something in the activities list view with focus in the the treeview a little entry appear at bottom/right, instead of sending the keys to the search control. The same happen in the Journal and in the ObjectChooser.

We can disable the search box, with set_enable_search(False) or probably better, use set_serch_entry

Change History (7)

comment:1 Changed 8 years ago by godiard

  • Cc erikos added

I have tried using set_search_entry, but does not work as expected. I have sent a very simple patch to sugar-devel.

I think we can do self.set_can_focus(False) in the activity list too, to prevent the listview steal focus from the query entry, because right now, we can't do nothing with the keybord in the listview (scrolling?), but I am no so sure about this.

comment:2 Changed 8 years ago by erikos

  • Bug Status changed from Unconfirmed to New
  • Milestone changed from Unspecified by Release Team to 0.96
  • Version changed from Unspecified to Git as of bugdate

Patch has been submitted for review and has been approved.

http://lists.sugarlabs.org/archive/sugar-devel/2011-October/033882.html

comment:3 Changed 7 years ago by manuq

  • Resolution set to fixed
  • Status changed from new to closed

Testcase: 1. focus on the tree view, 2. start typing, 3. the keys should be sent to the search box, not to a new entry that appears at bottom/right.

Tested in build os5 of olpc. Works as expected, I will close this ticket now.

comment:4 Changed 7 years ago by manuq

  • Keywords olpc-test added

comment:5 Changed 7 years ago by manuq

  • Keywords olpc-test-pending added; olpc-test removed

comment:6 Changed 7 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

We no longer get the odd search dialog in OLPC 12.1.0 os8; but we do not shift focus when alphanumeric keys are used to the search dialog in the top corner either.

Filed #3557 to suggesting the offering the search dialog focus when certain keys are pressed (the Tree view intercepts some for scrolling purposes).

comment:7 Changed 6 years ago by dnarvaez

  • Milestone 0.96 deleted

Milestone 0.96 deleted

Note: See TracTickets for help on using tickets.