Opened 8 years ago

Closed 6 years ago

#3194 closed defect (notsugar)

Software update can cause appearance of system freeze

Reported by: dfarning Owned by: ajay_garg
Priority: High Milestone: Unspecified
Component: Dextrose Version: Unspecified
Severity: Major Keywords: DX3 QA
Cc: sascha_silbe, bernie, erikos, Dcastelo, m_anish Distribution/OS: Dextrose
Bug Status: Assigned

Description

In my setting -> Software update the system can appear freeze forever if the system can not connect to the network.

Attachments (1)

0002-sl-3194-Notify-user-of-connection-not-available-in-S.patch (3.3 KB) - added by ajay_garg 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by sascha_silbe

  • Component changed from untriaged to Dextrose
  • Owner set to m_anish

comment:2 Changed 8 years ago by m_anish

  • Cc sascha_silbe bernie added

So:

  1. Should we add a timeout to the updating process while it is checking for updates?

and/or

  1. Display something like 'Please be patient, this can take several seconds' message while it is checking for updates?

comment:3 Changed 8 years ago by m_anish

  • Cc erikos added

Ah! misread the ticket :(

I guess we should just display that: 'Cannot check for updates, please check your internet connection' or something similar...

For upstream as well, it doesn't display any messages to indicate that updating failed. It just says 'Your software is up to date' which is incorrect. Simon?

comment:4 Changed 7 years ago by m_anish

  • Bug Status changed from Unconfirmed to Assigned
  • Cc Dcastelo m_anish added
  • Owner changed from m_anish to ajay_garg
  • Priority changed from Unspecified by Maintainer to High
  • Severity changed from Unspecified to Major
  • Status changed from new to assigned

comment:5 Changed 7 years ago by ajay_garg

The patch "0001-sl-3195-Same-behaviour-of-cancel-buttons-in-Software.patch" (ticket sl#3195), along with "0002-sl-3194-Notify-user-of-connection-not-available-in-S.patch", can be tested as follows ::

  1. Disconnect any network.
  1. Go to Software-Update.
  1. Since the network is not outright available, the message "Cannot check for updates. Please

check your internet connection, and try running Software Update again" will appear.
Now, the only way to restart the operation is that user goes out, and re-enters the Software-
Update section.

  1. Come out of the Software-Update section.
  1. Connect to the network.
  1. Go to Software-Update.
  1. Now, the "Checking for updates" message should appear, and operation should proceed.
  1. If "Cancel" is clicked anytime, it will have the same effect, as the "X" button on the toolbar (in this case, exit from the section-view).
  1. One particular use-case -- if the network is available at the start, but goes out midway, then the user will be stuck at "Checking for updates" message. Following two things may then happen ::

(i) network returns after some time -- Then, the operation WILL proceed to completion (confirmed by testing).

(ii) network does not return -- The same message "Checking for updates" will continue to be seen. User may exit (by clicking "cancel", or "X").

comment:6 Changed 7 years ago by m_anish

  • Priority changed from High to Urgent

comment:7 Changed 7 years ago by m_anish

  • Priority changed from Urgent to High

Dextrose-3 no longer ships its own microformat updater in the immediate term, rather ships the OLPC updater. Reducing severity:priority.

comment:8 Changed 6 years ago by dnarvaez

  • Resolution set to notsugar
  • Status changed from assigned to closed

Dextrose is not tracked here anymore.

Note: See TracTickets for help on using tickets.