Opened 8 years ago

Closed 5 years ago

#3188 closed defect (fixed)

The my settings search dialog behaves oddly.

Reported by: dfarning Owned by: ajay_garg
Priority: Normal Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Minor Keywords: dx3
Cc: dnarvaez Distribution/OS: Unspecified
Bug Status: New

Description

In the my setting screen ( which appears as a modal dialog) the user is able to select the search bar in the back ground dialog. Then when the user types the key strokes appear in the front search bar.

dx3 41
XO 1.5

Change History (10)

comment:1 Changed 7 years ago by m_anish

  • Bug Status changed from Unconfirmed to Assigned
  • Owner set to ajay_garg
  • Priority changed from Unspecified by Maintainer to Normal
  • Status changed from new to assigned

comment:2 Changed 6 years ago by dnarvaez

  • Component changed from untriaged to sugar

Temptatively assigning to sugar.

comment:3 Changed 6 years ago by dnarvaez

  • Bug Status changed from Assigned to Unconfirmed

comment:4 Changed 6 years ago by manuq

  • Bug Status changed from Unconfirmed to New
  • Distribution/OS changed from Dextrose to Unspecified
  • Severity changed from Unspecified to Minor

Confirmed. TestCase:

  • go to Home view
  • open frame, click XO icon on left panel, click My Settings
  • click the search entry in the background, which is outside the modal dialog
  • press keys

Expected behaviour: no action.
Current behaviour: the last letter is shown in the My Settings search box.

comment:5 Changed 5 years ago by godiard

Now is worst than in 12.1.0

Before, all the cursor was displayed in the search entry in the home window,
but all the text was added to the filter in the cp and the filter worked,
now the cursor is not displayed, but only the last letter is sent to
the cp search entry, then the filter is broken.

comment:6 Changed 5 years ago by dnarvaez

I don't think this is related to modality and clicking outside the control panel at all. Try to just start the control panel and type something (without focusing search), you will get the same behavior. The issues are caused by this code, if you remove it, the UI behaves sanely

https://github.com/sugarlabs/sugar/blob/master/src/jarabe/controlpanel/gui.py#L205

That feels like an hack to me. I'm not sure if it can be made to work. I'd rather just focus the entry when opening the window/coming back from sections... Or something like that.

comment:7 Changed 5 years ago by dnarvaez

Well it *might* be related to modality, because the same hack seems to work in the home views. But it's not related to clicking outside the window, that just causes the focus to move out of the entry, which is probably expected.

comment:8 Changed 5 years ago by dnarvaez

  • Cc dnarvaez added

comment:9 Changed 5 years ago by dnarvaez

Ufff, ignore my comments. I swear I had reproduced the issue when just opening the dialog, but now I don't see it anymore. Confused :/

comment:10 Changed 5 years ago by Gonzalo Odiard

  • Resolution set to fixed
  • Status changed from assigned to closed

Fix control panel search focus issue - SL #3188

Check if the window is active.

Fixes #3188

Signed-off-by: Gonzalo Odiard <gonzalo@…>

Changeset: 0c80477e4424160af76baf3e950d0eb31ee90d02

Note: See TracTickets for help on using tickets.